summaryrefslogtreecommitdiff
path: root/sys-boot/refind/files/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/refind/files/makefile.patch')
-rw-r--r--sys-boot/refind/files/makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-boot/refind/files/makefile.patch b/sys-boot/refind/files/makefile.patch
new file mode 100644
index 000000000000..5db6f75b1919
--- /dev/null
+++ b/sys-boot/refind/files/makefile.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -161,8 +161,9 @@ fs_edk2: build_edk2
+ done
+
+ build_edk2: $(EDK2BASE)/RefindPkg
+- cd $(EDK2BASE) && \
+- . ./edksetup.sh BaseTools && \
++ +cd $(EDK2BASE) && \
++ . udk-workspace && \
++ build -a $(UC_ARCH) -p MdePkg/MdePkg.dsc && \
+ build -a $(UC_ARCH) -p RefindPkg/RefindPkg.dsc
+ mkdir -p ./drivers_$(FILENAME_CODE)
+
+diff --git a/filesystems/Makefile b/filesystems/Makefile
+index 99452ed..9bc984d 100644
+--- a/filesystems/Makefile
++++ b/filesystems/Makefile
+@@ -5,6 +5,7 @@
+ # name of the driver to be built. This is done because of a dependency
+ # in the fsw_efi.c file on the filesystem type; this file must be
+ # recompiled for each new filesystem built.
++.NOTPARALLEL:
+
+ # This program is licensed under the terms of the GNU GPL, version 3,
+ # or (at your option) any later version.