summaryrefslogtreecommitdiff
path: root/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch')
-rw-r--r--sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch b/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch
new file mode 100644
index 000000000000..b5289244232a
--- /dev/null
+++ b/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.ac b/configure.ac
+index aad673e..592be5f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -122,7 +122,12 @@ AM_CONDITIONAL(ENABLE_SYSTEMD_INTEGRATION, [test "$enable_systemd_integration" =
+
+ if test x$enable_systemd_integration = xyes; then
+ AC_DEFINE(PLY_ENABLE_SYSTEMD_INTEGRATION, 1, [Coordinate boot up with systemd])
+- SYSTEMD_UNIT_DIR=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
++ AC_ARG_WITH([systemdsystemunitdir], AC_HELP_STRING([--with-systemdsystemunitdir=DIR],
++ [path to systemd service directory]), [path_systemdunit=${withval}],
++ [path_systemdunit="`$PKG_CONFIG --variable=systemdsystemunitdir systemd`"])
++ if (test -n "${path_systemdunit}"); then
++ SYSTEMD_UNIT_DIR="${path_systemdunit}"
++ fi
+ AC_SUBST(SYSTEMD_UNIT_DIR)
+ fi
+