summaryrefslogtreecommitdiff
path: root/sys-boot/efibootmgr/efibootmgr-16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-16.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-16.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-16.ebuild b/sys-boot/efibootmgr/efibootmgr-16.ebuild
new file mode 100644
index 000000000000..fc0c1a239f84
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
+SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ >=sys-libs/efivar-25:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-Werror //' Make.defaults || die
+}
+
+src_configure() {
+ tc-export CC
+ export EFIDIR="Gentoo"
+}