summaryrefslogtreecommitdiff
path: root/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild')
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
index 9fcd14b1d0ff..2fd4afa8a92a 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils
+inherit eutils toolchain-funcs
KERN_VER="2.6.22"
@@ -33,14 +33,18 @@ src_unpack() {
epatch "${FILESDIR}/aboot-pt_note.patch"
# Bug 364697
epatch "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
+ epatch "${FILESDIR}"/aboot-respect-AR.patch
+ epatch "${FILESDIR}"/aboot-gnu90.patch
# Modified patch from Debian to add netboot support
epatch "${WORKDIR}"/aboot_gentoo.diff
+
+ epatch_user
}
src_compile() {
# too many problems with parallel building
- emake -j1 || die "emake failed"
+ emake -j1 AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) || die "emake failed"
}
src_install() {