summaryrefslogtreecommitdiff
path: root/sys-block/whdd/whdd-3.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/whdd/whdd-3.0.1-r2.ebuild')
-rw-r--r--sys-block/whdd/whdd-3.0.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-3.0.1-r2.ebuild b/sys-block/whdd/whdd-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..7c5517686a86
--- /dev/null
+++ b/sys-block/whdd/whdd-3.0.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/dialog:=
+ sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}