summaryrefslogtreecommitdiff
path: root/sys-block/tgt
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/tgt')
-rw-r--r--sys-block/tgt/Manifest2
-rw-r--r--sys-block/tgt/tgt-1.0.74.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index ad3f3c096351..de9ff8029eb2 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -3,6 +3,8 @@ AUX tgtd.confd 108 BLAKE2B 74e5f66f6fb193541853e562cd1de5e99806f1f324db6efb5f9a5
AUX tgtd.initd 3435 BLAKE2B d2441a515c7a270472efd0c4ef5e928827bde54b248d09bb47f4fcc53c46e4678acf049c16ee761f29eb8e928f0713f38a9f73bd13db1e0408da56f42f64b337 SHA512 1e6d114dbb89c7a26e65546b6c775bcabc3c9508e0757e118a4272fbf4299a185b4679bc510d9cc3da7db25b96343ddc8e45de044543ebe26d952132eba4de30
DIST tgt-1.0.72.tar.gz 296698 BLAKE2B 6625bf87b37f4683aaf0c29264e69e400c6d238c9eaa7d9bb6fd46a76b542a8477ad8c7e9913d3dde70caaf02c323a2c01a3bd78b2d092829f4530015225012f SHA512 4fdb1b8f3c2487f66629024132f7fa53ab69b9eba67d380fb18aa2d9c143e77bdf808b3ff8d1e2bf1d4420cf1792944d6f79731ddbb095d52b53d573d9f1281c
DIST tgt-1.0.73.tar.gz 296814 BLAKE2B a3c81c00f716678aa9388f6a4562bd0b6fe0e2c705aee9655f942ffafae4bab3bbbaff521a8b7aefab208a354e0c1c617b85cdd08247a77d1026d0482d2b6528 SHA512 e6410f16c54f71d9a33d511438169a0ca305a7b9a9dd6abbaae9f0b31c18223fa1f3a11b575322d3bb94df129b4f9b186079a7d7cbd27e31734151154edab1da
+DIST tgt-1.0.74.tar.gz 297109 BLAKE2B 8ad439a1df437b87a6bf94a8c0403c4ae26a6b77ddc3b44758134199efa5b55dafd09cd2ac3f1b12abc3a77077dffdcab1e9b2aa0a97fcd2e2c19ba24a5cd9cf SHA512 aa905b44a3495275549d4abe8542e2b6b086bbab79b83d2902cba1e6124889a8873d479d1111128416b23c7681433fbe37c1772e8578bb12bf80b96267f65c0a
EBUILD tgt-1.0.72.ebuild 1563 BLAKE2B 7364870afeaca18d51b156690ca59f0db9637c78c6e1dc61cce3df8861be244d6b43fdc0bf8d2dd689f8ff879b87e6b395f8434fed0495ae763e702759aa4173 SHA512 f4a1bffcae7471dbdf4bad933c5b7ff82b6656da570c739aaec192389a1ae888ed8083cdb34340407a3eda692eb147aa177e5a8b59077ad22467332980c755a1
EBUILD tgt-1.0.73.ebuild 1514 BLAKE2B c64c89359f7054020fa130ae559a7da2f14b76368e88bc6a642a99c5ca085bc27b23f650a5b148db65595acb4132a200c43f9af82ce2c1d423d3cd674a979737 SHA512 10d945d72aaa099a6d29a669ae0e80f31056946c62947ae180d9fac446cd1d842dd52d908c7fc2db88764d5672187571bb11795851dfc3444e5aa96f3ae909cb
+EBUILD tgt-1.0.74.ebuild 1513 BLAKE2B f06f888d9954f29953bf8c82a47562c4fa96d63f4605ee1b97f0b3cec2cac389cf2289bce8c2ead1840b342c9b052ea36df235532819588b8a1548cf5d5cfdf1 SHA512 0ba464498acd2e6c78a8f39a65978909abe550c420362a0bf96fee74a37ff720f72a12f56873212abfc0f45ce678e7ccc673f31eb817f5af4f80c01a917e3067
MISC metadata.xml 825 BLAKE2B 89a6844eade4098443db47dcd5b3350c1bd6f4c0ffbdb6277df5714fdfd248d056f770f05e1392d64b573a28ca9db140dc7130e0109075c7fd398677ca251af9 SHA512 0c75be2e830ff683c8cae93175504a1e6508131d704c48d31b9fe98baa6b3a1e491661fda6180c0c1e35ef7e9bd57309d05e07b41160a7cc090934913e186f9f
diff --git a/sys-block/tgt/tgt-1.0.74.ebuild b/sys-block/tgt/tgt-1.0.74.ebuild
new file mode 100644
index 000000000000..694e0af3cf3b
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.74.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+MY_TREE="f33f6b7"
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="fcoe fcp ibmvio infiniband rbd"
+
+CDEPEND="dev-perl/Config-General
+ dev-libs/libxslt
+ rbd? ( sys-cluster/ceph )
+ infiniband? (
+ sys-fabric/libibverbs:=
+ sys-fabric/librdmacm:=
+ )"
+DEPEND="${CDEPEND}
+ app-text/docbook-xsl-stylesheets"
+RDEPEND="${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils"
+
+S=${WORKDIR}/fujita-tgt-${MY_TREE}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ eapply_user
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd tgtd
+ newconfd "${FILESDIR}"/tgtd.confd tgtd
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}