summaryrefslogtreecommitdiff
path: root/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
new file mode 100644
index 000000000000..c0237e11495b
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.73[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}