summaryrefslogtreecommitdiff
path: root/sys-block/rts_pstor/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/rts_pstor/files')
-rw-r--r--sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch36
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-makefile-kernel-5.1.patch7
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-makefile.patch8
3 files changed, 0 insertions, 51 deletions
diff --git a/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch b/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
deleted file mode 100644
index 7ea6ba6fd26b..000000000000
--- a/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/rtsx.h
-+++ b/rtsx.h
-@@ -81,6 +81,17 @@
- pci_get_domain_bus_and_slot(0, (bus), (devfn))
- #endif
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
-+static void do_gettimeofday(struct timeval *tv)
-+{
-+ struct timespec64 now;
-+
-+ ktime_get_real_ts64(&now);
-+ tv->tv_sec = now.tv_sec;
-+ tv->tv_usec = now.tv_nsec / 1000;
-+}
-+#endif
-+
- /*
- * macros for easy use
- */
---- a/rtsx.c
-+++ b/rtsx.c
-@@ -300,11 +300,13 @@
-
- .max_sectors = 240,
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
- /* merge commands... this seems to help performance, but
- * periodically someone should test to see which setting is more
- * optimal.
- */
- .use_clustering = 1,
-+#endif
-
-
- .emulated = 1,
diff --git a/sys-block/rts_pstor/files/rts_pstor-makefile-kernel-5.1.patch b/sys-block/rts_pstor/files/rts_pstor-makefile-kernel-5.1.patch
deleted file mode 100644
index ff527e8a530a..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-makefile-kernel-5.1.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -36,3 +36,3 @@
- cp -f ./define.release ./define.h
-- make -C /lib/modules/$(shell uname -r)/build/ SUBDIRS=$(PWD) modules
-+ +make -C $(KERNELDIR) M=$(PWD) modules
- debug:
diff --git a/sys-block/rts_pstor/files/rts_pstor-makefile.patch b/sys-block/rts_pstor/files/rts_pstor-makefile.patch
deleted file mode 100644
index dc12cd68f52b..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-makefile.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff -N -a -u1 a/Makefile b/Makefile
---- a/Makefile 2016-01-03 14:41:40.000000000 +0100
-+++ b/Makefile 2018-12-11 23:47:44.942218496 +0100
-@@ -36,3 +36,3 @@
- cp -f ./define.release ./define.h
-- make -C /lib/modules/$(shell uname -r)/build/ SUBDIRS=$(PWD) modules
-+ +make -C $(KERNELDIR) SUBDIRS=$(PWD) modules
- debug: