summaryrefslogtreecommitdiff
path: root/sys-block/open-isns/open-isns-0.99.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/open-isns/open-isns-0.99.ebuild')
-rw-r--r--sys-block/open-isns/open-isns-0.99.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-block/open-isns/open-isns-0.99.ebuild b/sys-block/open-isns/open-isns-0.99.ebuild
deleted file mode 100644
index e7290c1b77b5..000000000000
--- a/sys-block/open-isns/open-isns-0.99.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-DESCRIPTION="iSNS server and client for Linux"
-HOMEPAGE="https://github.com/open-iscsi/open-isns"
-SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug slp ssl static"
-
-DEPEND="
- ssl? (
- dev-libs/openssl:0=
- )
- slp? ( net-libs/openslp )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
- append-lfs-flags
- local myeconfargs=(
- $(use_with slp)
- $(use_with ssl security)
- $(use_enable !static shared)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" install_hdrs
- emake DESTDIR="${D}" install_lib
- keepdir /var/lib/${PN/open-}
- if ! use static ; then
- find "${ED}" -type f -name "*.a" -delete || die
- fi
-}