summaryrefslogtreecommitdiff
path: root/sys-block/megacli
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/megacli')
-rw-r--r--sys-block/megacli/Manifest1
-rw-r--r--sys-block/megacli/megacli-8.07.14-r2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-block/megacli/Manifest b/sys-block/megacli/Manifest
index 95d915b9d520..f4d04d29b3f3 100644
--- a/sys-block/megacli/Manifest
+++ b/sys-block/megacli/Manifest
@@ -4,5 +4,6 @@ DIST 8.07.10_MegaCLI_Linux.zip 1543709 BLAKE2B 6b42195d105faa5ce6469d6a36c37a1d8
DIST 8.07.14_MegaCLI.zip 7939395 BLAKE2B 3b4151724fab8b9fd2a5797d11919c52cdd5c96fefb6074fad6637a9a82a6d9291dd43e5480669779dbce18f3cb0c56fe119e868a6d6a7c9d05779eb6fccb154 SHA512 ee2b66b69dc41bb678e54f5ccf4908a51e6fde147b2118844ff6248127aa51f12af0e7562c74461d52ea8e9b4345877b21c87fc89210208d80cf2fd3402a93e3
EBUILD megacli-8.07.10.ebuild 2095 BLAKE2B db73b68bfb37be536e2254d29cdb0b71cd8bdbe9bf59ef0fd7c15ca7865993f0a962d533b2d24ea38783998bdb1cc420143bb286f03bf764df3d4523c562b41d SHA512 9c7eb12c22c7a82249419c04e9436f2eeec3e83b53fbb53c99bfdc6dd44a2d929539e6bb3839bef1514949999129214b7b396b400cf9a0acbc8beb89adee0b12
EBUILD megacli-8.07.14-r1.ebuild 2503 BLAKE2B 9d622084adb012d468c002ffd5556501fffeaa491c5e1a570be28a60606e01565f35e7dd3bbe5ec0376a32e3fa05989d2a641262f76dc313f37ca2c4403cf0d4 SHA512 a15d74ce1007e4d2399ff101374e81dba943114c959e68421a1c0ba8efe62630fb7d92050b239c8fe8561b18959c5ab376de780234e5dee2b9790d75b396d311
+EBUILD megacli-8.07.14-r2.ebuild 2488 BLAKE2B 196b2d912e47013d69517870e32bb295eae4bba05a392dbb0526979a0c3da7b3a757bd63b1e209eb48eda7769bfc9df0d1c219d3a738a1020f3ca6132b616f18 SHA512 bbe006cbcf1ecc9fec09df62ea1ecfa9d9d4657e9b5230d0f11f524565fde563953a584576b2b0684967a3cb8512ac38cfb993d88c008c3cb7d7d9aa458542e2
EBUILD megacli-8.07.14.ebuild 2055 BLAKE2B 9a630e8908e6f1b120944e0feac9ab4e0b9dba1195fc969ae1686c8a27f28a405953b12ee5f6bef09ae877db81472fd3efe96637cb64f9f872e4d19c076f2aa4 SHA512 ee9885306d50b1c74efc4dfedc275fd03c5472ccbf008202674a3a9e62e2ccf970a36c7e72b5c9e44b2a0ac06e46e445617e93362680f227afe3fd7d5314c91f
MISC metadata.xml 318 BLAKE2B 98c2744d890564a2aee5a9541954654e57d97c3a30ca9d2470afb2d0d63935eadf02d7745b617bb9f0d076bc449ed5f10fbf4610226d3f701077d6e4c3929ab9 SHA512 d2c34bba25ecc086ba1e3e009fbcf56d40efa3522cbc8d1fd4e273a58d21d82c2fd159c25e9295939f713e1ed845d361645915060fef9bc71be9be3d4ef043ee
diff --git a/sys-block/megacli/megacli-8.07.14-r2.ebuild b/sys-block/megacli/megacli-8.07.14-r2.ebuild
new file mode 100644
index 000000000000..e211dc65c70c
--- /dev/null
+++ b/sys-block/megacli/megacli-8.07.14-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit rpm
+MY_PV="${PV//./-}"
+MY_P=${MY_PV}_MegaCLI
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+HOMEPAGE="https://www.broadcom.com/support/knowledgebase/1211161498596/megacli-cheat-sheet--live-examples https://www.broadcom.com/support/knowledgebase/1211161496959/megacli-commands"
+# This file is '[zip] MegaCLI 5.5 P2', Date: 01/20/2014 Size: 7753 KB
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_P}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+RDEPEND="sys-libs/ncurses-compat:5"
+
+S=${WORKDIR}
+
+# Previous releases from LSI directly required a click-through EULA; but the
+# upstream website no longer requires this consistently: most old files have
+# two or more download pages, and while one of the pages has a generic
+# click-through download form, the file-specific download page only requires
+# click-through on some items. See also sys-block/lsiutil
+RESTRICT="mirror bindist"
+QA_PREBUILT="/opt/${PN}/${PN}
+ /opt/${PN}/lib/*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rpm_unpack ./Linux/MegaCli-${PV}-1.noarch.rpm
+}
+
+src_install() {
+ newdoc "${PV}_MegaCLI.txt" RELEASE.txt
+
+ exeinto /opt/megacli
+ libsysfs=libstorelibir-2.so.14.07-0
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64;;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
+
+ exeinto /opt/${PN}/lib
+ doexe opt/MegaRAID/MegaCli/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ # Remove DT_RPATH
+ chrpath -d "${D}"/opt/${PN}/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}