summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.26.4.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest2
-rw-r--r--sys-auth/Manifest.gzbin9241 -> 9241 bytes
-rw-r--r--sys-auth/oath-toolkit/Manifest6
-rw-r--r--sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch80
-rw-r--r--sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-glibc228.patch100
-rw-r--r--sys-auth/oath-toolkit/metadata.xml1
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2-r3.ebuild77
8 files changed, 54 insertions, 263 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.26.4.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.26.4.ebuild
new file mode 100644
index 000000000000..e5e3ddda4634
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.26.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 2c67168b7b00..f562e6a36797 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,4 +1,6 @@
DIST AusweisApp2-1.26.3.tar.gz 10842706 BLAKE2B b18fdc67a24cca5be866ce3f2d59133732a8086d3f5711ac81783e66010e1590e9e06106ff60b6fb20910060610e483a924169e67f51feb2c82ec876761e7a2e SHA512 67fb6653a15df0c6182953e5bad19513d29b1ca90699e4f32145ded7f2a157ef2f0e98f00392548ba680fc9b08a95c6b4a9d6bd23fed6f1a000a2ac1de4ff52b
+DIST AusweisApp2-1.26.4.tar.gz 10874849 BLAKE2B 48af76cd6fcae0bf79967c45c5b5cd3588749737460c4486b637c8fdcc01fb424c6140ce38cba9607256f16049ce876dbc49c3733dec5494901c76f71c80b90f SHA512 435ea946e25aef4273699bdb446c02649b7d3292d781cd633297577c684dc5551a0ec716e26947336f4dda5dc30cd5795f87706f8300e400b4ccb3ffeef3988f
EBUILD AusweisApp2-1.26.3.ebuild 944 BLAKE2B 1fee7734742fc405b969f83fd3243faa77f460b978b90ccafc8583fad32830ff39fa29bb41b828526bc30a19229528cf136d5dcce3cd61115e3adb4d3e3713e8 SHA512 1a3357be96c1e0afd45b70b8d1b1f2f94b11f407055e00b39170c9c5d6450ed8e25df231c6d775f0a141da9964d84fe00ff667c18096f75c4ff21c2284616b3f
+EBUILD AusweisApp2-1.26.4.ebuild 946 BLAKE2B 02b7fe0cebec48ce0c0e736ae59dc4d4d2c149cc098a69447a90da4014c691ed23beacd14de6327fe1bcdf444253f40bfd2d067ac3898745bb6322298cf2f205 SHA512 66edcb74985f2c47de23d56f5a353488a2d393ba6c1df80cd54f1a2d321ab54f12ec7f1f5504b380ad627812c273209268bcd32df0c31f0438a4df6235e83216
EBUILD AusweisApp2-9999.ebuild 896 BLAKE2B a283585d7f09d304017e9f80f3e081fa96787d702e919aa9f9bcd229078b6d17a9eb3dfeb8782f8011530a6cd8a3ab72be12c88251d4675c1924dea66a77672c SHA512 f361e420657a46e8234517d204548fb69b14bc367be38aa1f85b411bdcd53fdb6dc7a6b3807cf22376f82abc076181965d633b50e4b01a5a7a1032bbf45c0165
MISC metadata.xml 338 BLAKE2B cc2c3169dbe9280f8ab769c2c2c38a691d0af53999169948243cca1200c2a6ef8bb2f97dcc0e8dcbd709f3660fa262bf5279d3acce525baefe91951f91f1eca7 SHA512 db2026e39095afa71c7431290d8032fb6cdf70138beb14ae5cc20f4c5d03a0fa334cd769c14fe1085520b8631947c35c654bbd686ccc2e60a308d19ef6eb9e83
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index 60b63c8ae371..344bc3894047 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
index dcabad284313..22db353cba1b 100644
--- a/sys-auth/oath-toolkit/Manifest
+++ b/sys-auth/oath-toolkit/Manifest
@@ -1,8 +1,4 @@
-AUX oath-toolkit-2.6.2-gcc7.patch 3526 BLAKE2B 07966d96b4362cb7c271fa745cf9be843e14db9cade77768a9f31bbb0435c4f1f56c81464630871ad337213cbdc97ed0c1cf9ad9d261e29812984bab767c1eb1 SHA512 4bf9bc8e176861f044c55aab6c6cb48dcd7ac1d887f71f08475cc1e7f2b14cb04edc8417532613433af35687169667b073ea57556c85114e5a763a03443a85b9
-AUX oath-toolkit-2.6.2-glibc228.patch 4786 BLAKE2B 7690a2b5249b7c668be5a516fa0a298d789ac4d259a27ea3b5c9d5a581990ebc2431074f7e7adcc61c03ce2e0979cfbd2220c4335959c3f4f7279e758b954451 SHA512 4d015bc760b9df074441f93cd94342aff595b5ad5215165d64c0557222123b821c791a87afcba15a3ce0acfbe6945d96330468673249f4a2b1dc1700ab9040b2
AUX oath-toolkit-2.6.7-new-xmlsec-tests.patch 2925 BLAKE2B c3e2e52ef75f99276b449d0520a1546a8b492d1572c4d293b7b876cb64661086d195f79a420dd763d8aab06e286c46a542a345178218a5f82e43f7ac6cb92079 SHA512 b99f6601ea2d1072b815e2975ebf352a3b20a185d96686b4abb96036c983e256d51e171fbf3af9df1783261bf0051779655ac6838d720956220696c06abde108
-DIST oath-toolkit-2.6.2.tar.gz 4295786 BLAKE2B 2b97ab73339647b560b46373922095f18655a167b613b15d4ee2fd507d430025628d20eb111ff1d8025e78646b1d61d9680a7082caba1c75d247bb1d8b9b99dd SHA512 201a702a05a2e9fb3a66d04750e1a34e293342126caf02c344954a0d9fd0daafe73ca7f1fe273be129ae555a29b82b72fa2b4770ea2ad10711924e1926ec2cfb
DIST oath-toolkit-2.6.7.tar.gz 5625279 BLAKE2B 23f377c51eb633bf01d6085d33c7362cd91b6bed1cf4c2bbf32dc9433849e20c53f6896b16e5056b13f420f6a65a3c593fa1dafd7e184ed9e52666d94a7f75d1 SHA512 50edff75c8366887d69cf4740c4cc3bdfc3e43cbd4910ff40f735bca489f0953d7e5a21130f12782ac7a1f2fb00f0db313aff139085f23daba78a69bc7b2eb12
-EBUILD oath-toolkit-2.6.2-r3.ebuild 1960 BLAKE2B 5ba1172ea4e690f409153407c60c7c2cf48e263a4491b1d71a47999ee08a94b787235a7aed597013a1f632bf8fbb1e5320533795e0e0731f0b752e71e19eaac8 SHA512 5792179865476769eebd4d7910556a9a9015172b56ac68a3837aef0efe8cf59aadea2d8f5704e49ed249a5b64e501ecbc10bebb3a3ff9f1c8c25119e91c93af7
EBUILD oath-toolkit-2.6.7-r2.ebuild 1435 BLAKE2B 6d344b7794665f8516cedd7b9f5f60ec03c479ad407f5cc16a2454729e3a236b2a72f5e535560ea227cfaf142fd667cdbf7c1cef61774b4df37d0b877ac9e65d SHA512 db75ea75dee20fc8640454719075e587e0b26134fb09365be72d450c8c0a79dace7a379961398edfba5a1669e39368fdaa078166d013c0aac3bd501cd164e191
-MISC metadata.xml 712 BLAKE2B ed16c10de342d5ec86e29f7047dc4a95180f20db76c9b1bc3667ec584b35f02892e8adec80d0d182467d673c2c0daeb10da5eab179bc1267f38802854fef7b7a SHA512 aaadb093d4c1f6f661340ae887e60e6ba9d3b349c76b90d05ba2f524efe294ff097bb314a2bd2caed642271b8d40b15ecb6f46fade693be6f19685795d69a1f2
+MISC metadata.xml 592 BLAKE2B c5428eac278df13bc3cf23e1d5dce5ac4802a262d9f586574035a54af1e0b70547d9ce645636159e3f0cd8942bd77fb4e4f2253ba962d373189ea17f209dc824 SHA512 ed86f998c76cbe3bbcf2e1efa7c91cca0d3872530b6194f8534ff41da407bb8b642c6742fae5a65f2fc216144c977ca33c1b7f414872e5e23c3862b01c256a43
diff --git a/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch b/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch
deleted file mode 100644
index 18a0a2779408..000000000000
--- a/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Bug: https://bugs.gentoo.org/618100
-Cherry-picked from upstream commits: https://github.com/coreutils/gnulib/commit/175b4e22f99e00996b72f822f5ae54dca8243d19
- https://github.com/coreutils/gnulib/commit/abae112b34572cd3869ce4fc81dddb5c2a7394c4
-
---- a/oathtool/gl/intprops.h
-+++ b/oathtool/gl/intprops.h
-@@ -23,6 +23,10 @@
- #include <limits.h>
- #include <verify.h>
-
-+#ifndef __has_builtin
-+# define __has_builtin(x) 0
-+#endif
-+
- /* Return a value with the common real type of E and V and the value of V. */
- #define _GL_INT_CONVERT(e, v) (0 * (e) + (v))
-
-@@ -222,20 +226,24 @@
- ? (a) < (min) >> (b) \
- : (max) >> (b) < (a))
-
--/* True if __builtin_add_overflow (A, B, P) works when P is null. */
--#define _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL (7 <= __GNUC__)
-+/* True if __builtin_add_overflow (A, B, P) works when P is non-null. */
-+#define _GL_HAS_BUILTIN_OVERFLOW \
-+ (5 <= __GNUC__ || __has_builtin (__builtin_add_overflow))
-+
-+#define _GL_HAS_BUILTIN_OVERFLOW_P \
-+ (7 <= __GNUC__ || __has_builtin (__builtin_add_overflow_p))
-
- /* The _GL*_OVERFLOW macros have the same restrictions as the
- *_RANGE_OVERFLOW macros, except that they do not assume that operands
- (e.g., A and B) have the same type as MIN and MAX. Instead, they assume
- that the result (e.g., A + B) has that type. */
--#if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
--# define _GL_ADD_OVERFLOW(a, b, min, max)
-- __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
--# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
-- __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
--# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
-- __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
-+#if _GL_HAS_BUILTIN_OVERFLOW_P
-+# define _GL_ADD_OVERFLOW(a, b, min, max) \
-+ __builtin_add_overflow_p (a, b, (a) + (b))
-+# define _GL_SUBTRACT_OVERFLOW(a, b, min, max) \
-+ __builtin_sub_overflow_p (a, b, (a) - (b))
-+# define _GL_MULTIPLY_OVERFLOW(a, b, min, max) \
-+ __builtin_mul_overflow_p (a, b, (a) * (b))
- #else
- # define _GL_ADD_OVERFLOW(a, b, min, max) \
- ((min) < 0 ? INT_ADD_RANGE_OVERFLOW (a, b, min, max) \
-@@ -315,7 +323,7 @@
- _GL_BINARY_OP_OVERFLOW (a, b, _GL_ADD_OVERFLOW)
- #define INT_SUBTRACT_OVERFLOW(a, b) \
- _GL_BINARY_OP_OVERFLOW (a, b, _GL_SUBTRACT_OVERFLOW)
--#if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
-+#if _GL_HAS_BUILTIN_OVERFLOW || _GL_HAS_BUILTIN_OVERFLOW_P
- # define INT_NEGATE_OVERFLOW(a) INT_SUBTRACT_OVERFLOW (0, a)
- #else
- # define INT_NEGATE_OVERFLOW(a) \
-@@ -349,10 +357,6 @@
- #define INT_MULTIPLY_WRAPV(a, b, r) \
- _GL_INT_OP_WRAPV (a, b, r, *, __builtin_mul_overflow, INT_MULTIPLY_OVERFLOW)
-
--#ifndef __has_builtin
--# define __has_builtin(x) 0
--#endif
--
- /* Nonzero if this compiler has GCC bug 68193 or Clang bug 25390. See:
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68193
- https://llvm.org/bugs/show_bug.cgi?id=25390
-@@ -369,7 +373,7 @@
- the operation. BUILTIN is the builtin operation, and OVERFLOW the
- overflow predicate. Return 1 if the result overflows. See above
- for restrictions. */
--#if 5 <= __GNUC__ || __has_builtin (__builtin_add_overflow)
-+#if _GL_HAS_BUILTIN_OVERFLOW
- # define _GL_INT_OP_WRAPV(a, b, r, op, builtin, overflow) builtin (a, b, r)
- #elif 201112 <= __STDC_VERSION__ && !_GL__GENERIC_BOGUS
- # define _GL_INT_OP_WRAPV(a, b, r, op, builtin, overflow) \
diff --git a/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-glibc228.patch b/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-glibc228.patch
deleted file mode 100644
index c43f7aee0fe7..000000000000
--- a/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-glibc228.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -ruN oath-toolkit-2.6.2.orig/liboath/gl/fseeko.c oath-toolkit-2.6.2/liboath/gl/fseeko.c
---- oath-toolkit-2.6.2.orig/liboath/gl/fseeko.c 2016-08-27 13:15:06.000000000 +0200
-+++ oath-toolkit-2.6.2/liboath/gl/fseeko.c 2018-10-27 22:07:53.836832404 +0200
-@@ -1,18 +1,18 @@
- /* An fseeko() function that, together with fflush(), is POSIX compliant.
-- Copyright (C) 2007-2016 Free Software Foundation, Inc.
-+ Copyright (C) 2007-2018 Free Software Foundation, Inc.
-
- This program is free software; you can redistribute it and/or modify
-- it under the terms of the GNU Lesser General Public License as published by
-- the Free Software Foundation; either version 2.1, or (at your option)
-+ it under the terms of the GNU General Public License as published by
-+ the Free Software Foundation; either version 2, or (at your option)
- any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- GNU Lesser General Public License for more details.
-+ GNU General Public License for more details.
-
-- You should have received a copy of the GNU Lesser General Public License along
-- with this program; if not, see <http://www.gnu.org/licenses/>. */
-+ You should have received a copy of the GNU General Public License along
-+ with this program; if not, see <https://www.gnu.org/licenses/>. */
-
- #include <config.h>
-
-@@ -33,9 +33,9 @@
- #endif
- #if _GL_WINDOWS_64_BIT_OFF_T
- # undef fseeko
--# if HAVE__FSEEKI64 /* msvc, mingw64 */
-+# if HAVE__FSEEKI64 && HAVE_DECL__FSEEKI64 /* msvc, mingw since msvcrt8.0, mingw64 */
- # define fseeko _fseeki64
--# else /* mingw */
-+# else /* mingw before msvcrt8.0 */
- # define fseeko fseeko64
- # endif
- #endif
-@@ -47,12 +47,13 @@
- #endif
-
- /* These tests are based on fpurge.c. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
-+ /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_read_end == fp->_IO_read_ptr
- && fp->_IO_write_ptr == fp->_IO_write_base
- && fp->_IO_save_base == NULL)
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
-- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
-+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
- # if defined __SL64 && defined __SCLE /* Cygwin */
- if ((fp->_flags & __SL64) == 0)
- {
-@@ -80,7 +81,7 @@
- #elif defined __minix /* Minix */
- if (fp_->_ptr == fp_->_buf
- && (fp_->_ptr == NULL || fp_->_count == 0))
--#elif defined _IOERR /* AIX, HP-UX, IRIX, OSF/1, Solaris, OpenServer, mingw, NonStop Kernel */
-+#elif defined _IOERR /* AIX, HP-UX, IRIX, OSF/1, Solaris, OpenServer, mingw, MSVC, NonStop Kernel, OpenVMS */
- if (fp_->_ptr == fp_->_base
- && (fp_->_ptr == NULL || fp_->_cnt == 0))
- #elif defined __UCLIBC__ /* uClibc */
-@@ -117,18 +118,19 @@
- if (pos == -1)
- {
- #if defined __sferror || defined __DragonFly__ || defined __ANDROID__
-- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
-+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
- fp_->_flags &= ~__SOFF;
- #endif
- return -1;
- }
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1
-+ /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_flags &= ~_IO_EOF_SEEN;
- fp->_offset = pos;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
-- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
--# if defined __CYGWIN__ || (defined __NetBSD__ && __NetBSD_Version__ >= 600000000)
-+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
-+# if defined __CYGWIN__ || (defined __NetBSD__ && __NetBSD_Version__ >= 600000000) || defined __minix
- /* fp_->_offset is typed as an integer. */
- fp_->_offset = pos;
- # else
-@@ -150,8 +152,8 @@
- fp_->_flags &= ~__SEOF;
- #elif defined __EMX__ /* emx+gcc */
- fp->_flags &= ~_IOEOF;
--#elif defined _IOERR /* AIX, HP-UX, IRIX, OSF/1, Solaris, OpenServer, mingw, NonStop Kernel */
-- fp->_flag &= ~_IOEOF;
-+#elif defined _IOERR /* AIX, HP-UX, IRIX, OSF/1, Solaris, OpenServer, mingw, MSVC, NonStop Kernel, OpenVMS */
-+ fp_->_flag &= ~_IOEOF;
- #elif defined __MINT__ /* Atari FreeMiNT */
- fp->__offset = pos;
- fp->__eof = 0;
diff --git a/sys-auth/oath-toolkit/metadata.xml b/sys-auth/oath-toolkit/metadata.xml
index 69b7c5ff26ec..96a71f111315 100644
--- a/sys-auth/oath-toolkit/metadata.xml
+++ b/sys-auth/oath-toolkit/metadata.xml
@@ -9,7 +9,6 @@
<name>Gentoo Sysadmin Project</name>
</maintainer>
<use>
- <flag name="pskc">Build tools &amp; library for the Portable Symmetric Key Container (PSKC) format per RFC6030</flag>
<flag name="pam">Build PAM module for pluggable login authentication for OATH</flag>
</use>
<upstream>
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r3.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r3.ebuild
deleted file mode 100644
index 742fc8913696..000000000000
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit pam autotools
-DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
-HOMEPAGE="http://www.nongnu.org/oath-toolkit/"
-SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-IUSE="pam pskc static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/icu:=
- pam? ( sys-libs/pam )
- pskc? ( <dev-libs/xmlsec-1.3.0:= )"
-DEPEND="${RDEPEND}
- test? ( dev-libs/libxml2 )
- dev-util/gtk-doc-am"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc7.patch
- "${FILESDIR}"/${P}-glibc228.patch
-)
-
-src_prepare() {
- default
-
- # Below files are verbatim copy. Effectively apply ${P}-gcc7.patch
- # to all of them.
- local s='oathtool/gl/intprops.h' d
- for d in {liboath/gl/tests,libpskc/gl,pskctool/gl}/intprops.h; do
- echo "Copy '${s}' to '${d}'"
- cp "${s}" "${d}" || die
- done
-
- # These tests need git/cvs and don't reflect anything in the final app
- sed -i -r \
- -e '/TESTS/s,test-vc-list-files-(git|cvs).sh,,g' \
- gl/tests/Makefile.am
- # disable portability warnings, caused by gtk-doc.make
- sed -i \
- -e '/AM_INIT_AUTOMAKE/ s:-Wall:\0 -Wno-portability:' \
- {liboath,libpskc}/configure.ac
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable test xmltest ) \
- $(use_enable pam) \
- $(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable pskc) \
- $(use_enable static-libs static)
-}
-
-src_test() {
- # without keep-going, it will bail out after the first testsuite failure,
- # skipping the other testsuites. as they are mostly independant, this sucks.
- emake --keep-going check
- [ $? -ne 0 ] && die "At least one testsuite failed"
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -type f -delete || die
- if use pam; then
- newdoc pam_oath/README README.pam
- fi
- if use pskc; then
- doman pskctool/pskctool.1
- fi
-}