summaryrefslogtreecommitdiff
path: root/sys-auth/ssh-import-id
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/ssh-import-id')
-rw-r--r--sys-auth/ssh-import-id/Manifest3
-rw-r--r--sys-auth/ssh-import-id/metadata.xml3
-rw-r--r--sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild28
3 files changed, 33 insertions, 1 deletions
diff --git a/sys-auth/ssh-import-id/Manifest b/sys-auth/ssh-import-id/Manifest
index 021c146bd24a..7b075d06b42d 100644
--- a/sys-auth/ssh-import-id/Manifest
+++ b/sys-auth/ssh-import-id/Manifest
@@ -1,3 +1,4 @@
DIST ssh-import-id-5.11.tar.gz 146064 BLAKE2B d869ec480d224aa906ef08b5b9acfbf9324d67bffafadcf1c0adae108ad53e76cdfbcf0d1905a947bda5df507fbd69e7ee121890bc48e452ca67c5acd92ac18c SHA512 49703b8b9c127f13bf0626fd013318b9498ec8a67a060fb7607c7a1894da3e3e3e7e995c9b68af8375237f4031d06abda20f2a9a73a1fabbe33055f2f434716b
+EBUILD ssh-import-id-5.11-r1.ebuild 681 BLAKE2B 59126b8e58d56ddc2fecfa64dc8747f29fa36b3b54fbdd4295f329a5aa1e6878b5fc6a79777c06b482761e935d6b7207a5a59222b6a0665ec56e679f397ee857 SHA512 32adf6275135c540fc3614e8f4deb1b353074269d925e43f9c9825e1ef9b1236612b4fe96b25fd818efe653e4bcb793310bf39cd256cbc1165c3959bed7f249f
EBUILD ssh-import-id-5.11.ebuild 643 BLAKE2B 79487010604b3b453f626b2048fb5c8f49c28f1a7cb88b68f10ce969a285a028d9eae70d6bb74f7ae2ecfe0abeee98cc5c23b5a9d73995bab1b17e5f2fb86358 SHA512 32d64e6d17a6a46b0fe588d83805b5172fda014e5f62f92a1f7444df752aa1ed0723e9d350fffcfe66738c7b19cb5acee7a9fe9ea0173037ce5790966ad2a59f
-MISC metadata.xml 277 BLAKE2B c345d754d34cb228e1b27283b6a38bf4e4e87925b27cc8ca7bd1f8a752be7a3fede5ba13df3bb692a5cb3187476767c89fb1205dd8591a183cefe4b8f8b2e127 SHA512 71ba86560b0ee47075fb4bb3e953b5a39fff709ec53cc1c8f795df63f996b4377b9a367057512b7d620764d6744cb92ab2943aeeeba52b940c3a3cffdd270675
+MISC metadata.xml 358 BLAKE2B 91acc78cd37661bd253369897590130c448d89cdcfd324c3aa4e8f669540d742a3de9602642b1ce048e09ab7b1c7595e88186ea15ade1863dfce8dd22a9d9fcb SHA512 ad8fb377a3fc91116c3c64440d3bda1f7f9cd13d898544efa314b57e9ede5d54f566c7efbbbcae39fc37d07323f2c17163d9ec1532b968c5ce2b14a581ebd3d4
diff --git a/sys-auth/ssh-import-id/metadata.xml b/sys-auth/ssh-import-id/metadata.xml
index fd9ff4351985..77b851e114a2 100644
--- a/sys-auth/ssh-import-id/metadata.xml
+++ b/sys-auth/ssh-import-id/metadata.xml
@@ -6,4 +6,7 @@
<name>Piotr Karbowski</name>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="launchpad">ssh-import-id</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
new file mode 100644
index 000000000000..5e367ecf4375
--- /dev/null
+++ b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to securely retrieve an SSH public key and install it locally"
+HOMEPAGE="https://launchpad.net/ssh-import-id"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman usr/share/man/man1/ssh-import-id.1
+}