summaryrefslogtreecommitdiff
path: root/sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild')
-rw-r--r--sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild b/sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild
new file mode 100644
index 000000000000..656e7e1b3841
--- /dev/null
+++ b/sys-auth/pam_fprint/pam_fprint-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils pam
+
+DESCRIPTION="a simple PAM module which uses libfprint's functionality for authentication"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Pam_fprint"
+SRC_URI="mirror://sourceforge/fprint/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="sys-auth/libfprint
+ sys-libs/pam"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
+src_install() {
+ dopammod src/${PN}.so || die
+ newbin src/pamtest pamtest.fprint || die
+ dobin src/pam_fprint_enroll || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}