summaryrefslogtreecommitdiff
path: root/sys-auth/elogind/elogind-243.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/elogind/elogind-243.7.ebuild')
-rw-r--r--sys-auth/elogind/elogind-243.7.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-auth/elogind/elogind-243.7.ebuild b/sys-auth/elogind/elogind-243.7.ebuild
index 3354180300c6..b8d79dc55636 100644
--- a/sys-auth/elogind/elogind-243.7.ebuild
+++ b/sys-auth/elogind/elogind-243.7.ebuild
@@ -111,6 +111,16 @@ src_install() {
}
pkg_postinst() {
+ if ! use pam; then
+ ewarn "${PN} will not be managing user logins/seats without USE=\"pam\"!"
+ ewarn "In other words, it will be useless for most applications."
+ ewarn
+ fi
+ if ! use policykit; then
+ ewarn "loginctl will not be able to perform privileged operations without"
+ ewarn "USE=\"policykit\"! That means e.g. no suspend or hibernate."
+ ewarn
+ fi
if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
elog "elogind is currently started from boot runlevel."
elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then