summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49866 -> 49877 bytes
-rw-r--r--sys-apps/cinit/Manifest2
-rw-r--r--sys-apps/cinit/cinit-0.2.1-r1.ebuild42
-rw-r--r--sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch43
-rw-r--r--sys-apps/usermode-utilities/Manifest2
-rw-r--r--sys-apps/usermode-utilities/files/usermode-utilities-fix-memset.patch44
-rw-r--r--sys-apps/usermode-utilities/usermode-utilities-20070815-r5.ebuild47
7 files changed, 180 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 03df70de1246..7a7a03059a5e 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/cinit/Manifest b/sys-apps/cinit/Manifest
index 1e3de39e3af1..1cdf7161c2fa 100644
--- a/sys-apps/cinit/Manifest
+++ b/sys-apps/cinit/Manifest
@@ -1,3 +1,5 @@
+AUX cinit-0.2.1-musl-clang16-build-fix.patch 1582 BLAKE2B afadee30b5de75c84d945622af2790eac58d7708a1f153b1aaba0f4bf78910cd778481f1e58cb097a1254f1ebdab67feba73b2b5af1073162e12905de8e7fe30 SHA512 b8764788e0ed934cb608248281a5ec19bc7b35e109989a34cb6cf95bc727ca9b01c35a5cf35a6c57a820fa5ebae5fdcbc825eebed2d2920873d8d0499d1ea27c
DIST cinit-0.2.1.tar.bz2 63545 BLAKE2B ef45cc1a2622d4dbf36e47fab2d09a576ea726e3aa2ac928827dae63fd976daf3dee3d91de21bc1f66200fcb90aecd267b0e9fef9575e525b8e75d00a0f818a5 SHA512 fce6a0c06b11a252023f7f0159fdfe4f9f4dc3c1545708997c148ed2f0a451bb68a5b98518fc48083e3518959d28b32b1719a9b89d00af7a997854230fca09d7
+EBUILD cinit-0.2.1-r1.ebuild 924 BLAKE2B 47a0dcf68cb2de7745ccfd6ea77b0b065c196fd624bd7b1c7fcabfe38a9d75d0b0a8d3b4390434b8597db460808d50588f286391966da05d7834d56f996f9e8e SHA512 bf3604a9ea75422d4b97d645931639b22bfc4c739c1796b56e444125d7b962d3710d0e546b72d24129879cff01e52debcaca09e98300524d278de3a9d6cb750a
EBUILD cinit-0.2.1.ebuild 855 BLAKE2B a509bcb0455f8b83af97fa2604e17fe7fbfe334e48781b407be5d1c466c819e9852a5cac18163aec5dd3ea8e81534e781f5c3e4a9f394e34052de6da5f015b08 SHA512 a5829fa70951104d1b0a9f326b4cb5706fd558af1fad96ca5143e28522169fda92ad7eb7da319407eea8c1739edc30b0fcc30b38f6ac37ee664b898f08e8df1f
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/sys-apps/cinit/cinit-0.2.1-r1.ebuild b/sys-apps/cinit/cinit-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..22cbed1f0264
--- /dev/null
+++ b/sys-apps/cinit/cinit-0.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a fast, small and simple init with support for profiles"
+HOMEPAGE="http://linux.schottelius.org/cinit/"
+SRC_URI="http://linux.schottelius.org/${PN}/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.1-musl-clang16-build-fix.patch
+)
+
+src_prepare() {
+ sed -i "/contrib+tools/d" Makefile || die
+ sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I." \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP=/bin/true \
+ all
+}
+
+src_install() {
+ emake LD="$(tc-getCC)" DESTDIR="${D}" install
+ rm -f "${D}"/sbin/{init,shutdown,reboot} || die
+ dodoc Changelog CHANGES CREDITS README TODO
+ use doc && dodoc -r doc
+}
diff --git a/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch b/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch
new file mode 100644
index 000000000000..832e0590b5c6
--- /dev/null
+++ b/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch
@@ -0,0 +1,43 @@
+With musl and clang16 the following build error occurs:
+
+client/run_run_svcs.c:24:17: error: use of undeclared identifier 'PATH_MAX'
+ char pathbuf[PATH_MAX+1];
+ ^
+client/run_run_svcs.c:28:21: warning: if statement has empty body [-Wempty-body]
+ D_PRINTF(abspath);
+ ^
+client/run_run_svcs.c:28:21: note: put the semicolon on a separate line to silence this warning
+client/connect_sock.c:28:4: error: call to undeclared library function 'memset' with type
+ 'void *(void *, int, unsigned long)'; ISO C99 and later do not support implicit function declarations
+ [-Wimplicit-function-declaration]
+ memset(&addr,0,socke);
+ ^
+client/connect_sock.c:28:4: note: include the header <string.h> or explicitly provide a declaration for
+ 'memset'
+client/connect_sock.c:29:4: error: call to undeclared library function 'strcpy' with type
+ 'char *(char *, const char *)'; ISO C99 and later do not support implicit function declarations
+ [-Wimplicit-function-declaration]
+ strcpy(addr.sun_path, CINIT_SOCK);
+
+This patch fixes all three of those errors
+Bug: https://bugs.gentoo.org/898542
+--- a/client/connect_sock.c
++++ b/client/connect_sock.c
+@@ -8,6 +8,7 @@
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include "cinit.h"
+
+--- a/client/run_run_svcs.c
++++ b/client/run_run_svcs.c
+@@ -3,6 +3,7 @@
+ * (c) 2005 Nico Schottelius (nico-linux at schottelius.org)
+ * run services parallel
+ */
++#include <linux/limits.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <dirent.h>
diff --git a/sys-apps/usermode-utilities/Manifest b/sys-apps/usermode-utilities/Manifest
index a1c9b50f2be7..296f4b91ded8 100644
--- a/sys-apps/usermode-utilities/Manifest
+++ b/sys-apps/usermode-utilities/Manifest
@@ -1,6 +1,8 @@
AUX usermode-utilities-20070815-headers.patch 491 BLAKE2B 0c4e274101ada3c084cd6573247259c54d58c92e680a2a7a14f914e935e90bc6563631ec8d3ef3a7b417ce44dddbbe20a269f1beaa6896e3d53608fb07b13c24 SHA512 962d7df2497374ec418861522fc7b6be25b295bed11fbf86bdf149e7e6730e2a1f34475eef9b8216ad2576eabe7f56e230a912b3ca415da3e1e5adc3ebce769b
AUX usermode-utilities-20070815-humfsify-owner.patch 460 BLAKE2B 5135621f69d9f923021059606c9faf1089ad7ee3273224a40ad570e233664dd781c633f7af61e41cacd2bdda298e23a79e04ec71a38875c95f9649a886d0b93e SHA512 f048d1fde80a5fae33a67c99aad5927f64343a1bec15cdab94bb5c8798b96192fccedda66a9aa8f14fb90de803cba031ddec4d9bc6eec236b8245aaa7b74115f
AUX usermode-utilities-20070815-rollup.patch 4619 BLAKE2B d8701507d464fa10ebb99663dbf32c1d57040059bf7f43fcbcef82637d98d51ca55cd4fb28c7d7feb79c9b1597f4aa7ac01e7494e1db5549f75445ef9ba7854b SHA512 9cfc5a2fa98b7aff45c732629812ab691d3a56e5526f70d9ddb93dd666b9bf743296914f63043a94611e045915ed8046c87507a451deebc3d889d0827dc76439
+AUX usermode-utilities-fix-memset.patch 1156 BLAKE2B 4349f038f768649c9ae1dcccb4aeb718a9866e6373910636359529acefd85e734374f41accd2453bb0312a134bc730e5e826123d052ed8fa81068db7ade911e7 SHA512 933eb6b78740fcc3d3f3e8f55624cce9a078ed7c70b74741cb27a324f9076e24f3eeff40b4b8cdfb56258a9007f1833b67fb1b7a7e61afa037f8c79d7c0d7380
DIST uml_utilities_20070815.tar.bz2 50159 BLAKE2B d11e7bc92892f2f5bc655bf580d66b1364d2c1f8e97e85ff39a6aeb85ed979c33c1d7c084b0a5e442df5622f7fa657677a322748e44c7ecf67f14d6b39a7536c SHA512 a246ca04bcba2282ceb976e69399f496cc85d14ee13c1e4704f943d7fcef032eda92e9e8c4341f6e8878c6353ed97c7f77b283e62e152987c792a7a6258f1d1a
EBUILD usermode-utilities-20070815-r4.ebuild 1272 BLAKE2B 19c421c2680e7b953f6c7ea19ecf8c32f525b0f4038da8495937626812e93e9c4ae1ee3f6112dbb5ba6c0ac9d44e45e8ba409722387e176482793fef71ecd516 SHA512 d2c36f0308eba22a98ee6d122ad5333ee8737d1343a5fa1a0608d20ec4246eeb1c18c48b68edbb0f2773485e444d4b8d77ec2e89d726498fff197b03023169d5
+EBUILD usermode-utilities-20070815-r5.ebuild 1341 BLAKE2B 5fa6caeed330be7f8804cc1bab7fcf605e18ed3a4821b5d2212420396c2151dd37dfe8b727db860191b15bfd74fbe77f2dff56c9ee0c03e1fe7e57ed874cedf1 SHA512 b51646ab882ab67bc133cd0f9a8e0b4ffcb4323c8739ba42ebac03751c4f302e053e8834cb4b658b5cbb3c11b0152fa6b234ba1a85936681d58cd4243e372b51
MISC metadata.xml 341 BLAKE2B b7a6e0570e65cbc1ba6e97a752b15bae8e16a6e0edb98cb3bf96bec7b98d6fd827c01db69e629cd919cd8301932c3fc257fbf28d70eabb8d69e3c94d0fc7cb58 SHA512 47dfce7cd9fe15abf8399d8e87e3e3f6fbf5bf1763cc02d2272c116cea3bdfee1ff2838ea10e26d62645252df0ef958dca5426758a4e5f9469296dd06bc8789e
diff --git a/sys-apps/usermode-utilities/files/usermode-utilities-fix-memset.patch b/sys-apps/usermode-utilities/files/usermode-utilities-fix-memset.patch
new file mode 100644
index 000000000000..39c036ae52ba
--- /dev/null
+++ b/sys-apps/usermode-utilities/files/usermode-utilities-fix-memset.patch
@@ -0,0 +1,44 @@
+Fix building with clang-16, as lot of functions from string.h (including
+memset) couldn't be found. Resulting in error: call to undeclared library
+function memset type error.
+Bug: https://bugs.gentoo.org/898550
+--- a/port-helper/port-helper.c
++++ b/port-helper/port-helper.c
+@@ -13,6 +13,7 @@ for read and write, and the console is functional.
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <signal.h>
++#include <string.h>
+ #include <errno.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+--- a/uml_switch/port.c
++++ b/uml_switch/port.c
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <errno.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+--- a/uml_switch/uml_switch.c
++++ b/uml_switch/uml_switch.c
+@@ -6,6 +6,7 @@
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <signal.h>
++#include <string.h>
+ #include <fcntl.h>
+ #include <stdint.h>
+ #include <sys/socket.h>
+--- a/watchdog/uml_watchdog.c
++++ b/watchdog/uml_watchdog.c
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
++#include <string.h>
+ #include <errno.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
diff --git a/sys-apps/usermode-utilities/usermode-utilities-20070815-r5.ebuild b/sys-apps/usermode-utilities/usermode-utilities-20070815-r5.ebuild
new file mode 100644
index 000000000000..4231042d1b43
--- /dev/null
+++ b/sys-apps/usermode-utilities/usermode-utilities-20070815-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tools for use with Usermode Linux virtual machines"
+HOMEPAGE="http://user-mode-linux.sourceforge.net/"
+SRC_URI="http://user-mode-linux.sourceforge.net/uml_utilities_${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="fuse"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0= )
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/tools-${PV}
+
+PATCHES=(
+ # Merge previous patches with fix for bug #331099
+ "${FILESDIR}"/${P}-rollup.patch
+ # Fix owner of humfsify; bug #364531
+ "${FILESDIR}"/${P}-humfsify-owner.patch
+ "${FILESDIR}"/${P}-headers.patch #580816
+ # Fix build /w clang-16, bug #898550
+ "${FILESDIR}"/${PN}-fix-memset.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e 's:-o \$(BIN):$(LDFLAGS) -o $(BIN):' "${S}"/*/Makefile || die "LDFLAGS sed failed"
+ sed -i -e 's:-o \$@:$(LDFLAGS) -o $@:' "${S}"/moo/Makefile || die "LDFLAGS sed (moo) failed"
+ if ! use fuse; then
+ einfo "Skipping build of umlmount to avoid sys-fs/fuse dependency."
+ sed -i -e 's/\<umlfs\>//' Makefile || die "sed to remove sys-fs/fuse dependency failed"
+ fi
+}
+
+src_compile() {
+ tc-export AR CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS} -DTUNTAP -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -g -Wall" all
+}