summaryrefslogtreecommitdiff
path: root/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild')
-rw-r--r--sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild70
1 files changed, 38 insertions, 32 deletions
diff --git a/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild b/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
index 01082d0ebeb1..54d71a2f8c9c 100644
--- a/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
+++ b/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
@@ -22,18 +22,19 @@ CRATES="
binary-heap-plus@0.5.0
bindgen@0.63.0
bitflags@1.3.2
- bitflags@2.4.0
+ bitflags@2.4.2
blake2b_simd@1.0.2
- blake3@1.5.0
+ blake3@1.5.1
block-buffer@0.10.3
- bstr@1.9.0
+ bstr@1.9.1
bumpalo@3.11.1
bytecount@0.6.7
byteorder@1.5.0
cc@1.0.79
cexpr@0.6.0
cfg-if@1.0.0
- chrono@0.4.32
+ cfg_aliases@0.1.1
+ chrono@0.4.35
clang-sys@1.4.0
clap@4.4.2
clap_builder@4.4.2
@@ -63,7 +64,7 @@ CRATES="
crossterm_winapi@0.9.1
crunchy@0.2.2
crypto-common@0.1.6
- ctrlc@3.4.1
+ ctrlc@3.4.4
custom_derive@0.1.7
data-encoding-macro-internal@0.1.12
data-encoding-macro@0.1.14
@@ -77,8 +78,8 @@ CRATES="
encode_unicode@0.3.6
env_logger@0.8.4
errno@0.3.8
- exacl@0.11.0
- fastrand@2.0.0
+ exacl@0.12.0
+ fastrand@2.0.1
file_diff@1.0.0
filetime@0.2.23
flate2@1.0.24
@@ -102,7 +103,7 @@ CRATES="
generic-array@0.14.6
getrandom@0.2.9
glob@0.3.1
- half@2.3.1
+ half@2.4.0
hashbrown@0.13.2
hermit-abi@0.3.2
hex-literal@0.4.1
@@ -114,7 +115,7 @@ CRATES="
inotify-sys@0.1.5
inotify@0.9.6
io-lifetimes@1.0.11
- itertools@0.12.0
+ itertools@0.12.1
itoa@1.0.4
js-sys@0.3.64
keccak@0.1.4
@@ -122,13 +123,13 @@ CRATES="
kqueue@1.0.7
lazy_static@1.4.0
lazycell@1.3.0
- libc@0.2.152
+ libc@0.2.153
libloading@0.7.4
libm@0.2.7
linux-raw-sys@0.3.8
linux-raw-sys@0.4.12
lock_api@0.4.9
- log@0.4.17
+ log@0.4.20
lscolors@0.16.0
match_cfg@0.1.0
md-5@0.10.6
@@ -136,14 +137,14 @@ CRATES="
memmap2@0.9.0
minimal-lexical@0.2.1
miniz_oxide@0.5.4
- mio@0.8.10
- nix@0.27.1
+ mio@0.8.11
+ nix@0.28.0
nom@7.1.3
notify@6.0.1
nu-ansi-term@0.49.0
num-bigint@0.4.4
num-integer@0.1.45
- num-traits@0.2.17
+ num-traits@0.2.18
num_threads@0.1.6
number_prefix@0.4.0
once_cell@1.19.0
@@ -176,13 +177,14 @@ CRATES="
rand_chacha@0.3.1
rand_core@0.6.4
rand_pcg@0.3.1
- rayon-core@1.12.0
- rayon@1.8.0
+ rayon-core@1.12.1
+ rayon@1.9.0
redox_syscall@0.4.1
+ redox_syscall@0.5.0
reference-counted-singleton@0.1.2
regex-automata@0.4.4
regex-syntax@0.8.2
- regex@1.10.3
+ regex@1.10.4
relative-path@1.8.0
rlimit@0.10.1
roff@0.2.1
@@ -192,34 +194,35 @@ CRATES="
rustc-hash@1.1.0
rustc_version@0.4.0
rustix@0.37.26
- rustix@0.38.30
+ rustix@0.38.31
same-file@1.0.6
- scopeguard@1.1.0
+ scopeguard@1.2.0
self_cell@1.0.3
selinux-sys@0.6.2
selinux@0.4.0
semver@1.0.14
- serde@1.0.147
+ serde@1.0.193
+ serde_derive@1.0.193
sha1@0.10.6
sha2@0.10.8
sha3@0.10.8
- shlex@1.1.0
+ shlex@1.3.0
signal-hook-mio@0.2.3
signal-hook-registry@1.4.0
signal-hook@0.3.17
siphasher@0.3.10
slab@0.4.7
sm3@0.4.2
- smallvec@1.13.0
+ smallvec@1.13.1
smawk@0.3.1
socket2@0.5.3
strsim@0.10.0
syn@1.0.109
- syn@2.0.23
- tempfile@3.9.0
+ syn@2.0.32
+ tempfile@3.10.1
terminal_size@0.2.6
terminal_size@0.3.0
- textwrap@0.16.0
+ textwrap@0.16.1
thiserror-impl@1.0.37
thiserror@1.0.37
time-core@0.1.0
@@ -229,15 +232,15 @@ CRATES="
typenum@1.15.0
unicode-ident@1.0.5
unicode-linebreak@0.1.5
- unicode-segmentation@1.10.1
+ unicode-segmentation@1.11.0
unicode-width@0.1.11
unicode-xid@0.2.4
unindent@0.2.1
utf8parse@0.2.1
- uuid@1.2.2
+ uuid@1.7.0
uutils_term_grid@0.3.0
version_check@0.9.4
- walkdir@2.4.0
+ walkdir@2.5.0
wasi@0.11.0+wasi-snapshot-preview1
wasm-bindgen-backend@0.2.87
wasm-bindgen-macro-support@0.2.87
@@ -245,7 +248,7 @@ CRATES="
wasm-bindgen-shared@0.2.87
wasm-bindgen@0.2.87
which@4.3.0
- wild@2.2.0
+ wild@2.2.1
winapi-i686-pc-windows-gnu@0.4.0
winapi-util@0.1.6
winapi-x86_64-pc-windows-gnu@0.4.0
@@ -309,8 +312,7 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT Unicode-DFS-2016"
SLOT="0"
IUSE="debug selinux test"
-# TODO: Need to skip known-failing tests
-RESTRICT="!test? ( test )" # test
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/oniguruma:=
@@ -325,7 +327,7 @@ BDEPEND="
QA_FLAGS_IGNORED=".*"
PATCHES=(
- "${FILESDIR}"/${PN}-0.2.21-xfail-tests.patch
+ "${FILESDIR}"/${PN}-0.2.25-xfail-tests.patch
)
src_unpack() {
@@ -341,6 +343,10 @@ src_compile() {
# normally cargo_src_compile sets this for us, but we don't use it
filter-lto
+ # By default, the crate uses a system version if it can. This just guarantees
+ # that it will error out instead of building a vendored copy.
+ export RUSTONIG_SYSTEM_LIBONIG=1
+
makeargs=(
# Disable output synchronisation as make calls cargo
-Onone