summaryrefslogtreecommitdiff
path: root/sys-apps/util-linux/util-linux-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild22
1 files changed, 5 insertions, 17 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index f76687a5bc42..0baf9332ec6f 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -157,21 +157,6 @@ src_prepare() {
fi
}
-lfs_fallocate_test() {
- # Make sure we can use fallocate with LFS, bug #300307
- cat <<-EOF > "${T}"/fallocate.${ABI}.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
- EOF
-
- append-lfs-flags
-
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
- || export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.${ABI}.c
-}
-
python_configure() {
local myeconfargs=(
"${commonargs[@]}"
@@ -191,8 +176,6 @@ python_configure() {
}
multilib_src_configure() {
- lfs_fallocate_test
-
# The scanf test in a run-time test which fails while cross-compiling.
# Blindly assume a POSIX setup since we require libmount, and libmount
# itself fails when the scanf test fails. bug #531856
@@ -297,6 +280,11 @@ multilib_src_configure() {
fi
}
+src_configure() {
+ append-lfs-flags
+ multilib-minimal_src_configure
+}
+
python_compile() {
pushd "${BUILD_DIR}" >/dev/null || die
emake all