summaryrefslogtreecommitdiff
path: root/sys-apps/usbguard/usbguard-0.7.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbguard/usbguard-0.7.8.ebuild')
-rw-r--r--sys-apps/usbguard/usbguard-0.7.8.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-apps/usbguard/usbguard-0.7.8.ebuild b/sys-apps/usbguard/usbguard-0.7.8.ebuild
index 317ca17a882b..be1f9ae5b840 100644
--- a/sys-apps/usbguard/usbguard-0.7.8.ebuild
+++ b/sys-apps/usbguard/usbguard-0.7.8.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Daemon protecting your computer against BadUSB"
HOMEPAGE="https://github.com/USBGuard/usbguard"
SRC_URI="https://github.com/USBGuard/usbguard/releases/download/${P}/${P}.tar.gz"
@@ -45,6 +47,15 @@ DEPEND="${CDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.0-pthreads-link.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myargs=(
$(use_with dbus)