summaryrefslogtreecommitdiff
path: root/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild')
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild b/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild
new file mode 100644
index 000000000000..4b303d44dde3
--- /dev/null
+++ b/sys-apps/ucspi-unix/ucspi-unix-0.36-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A ucspi implementation for unix sockets"
+HOMEPAGE="http://untroubled.org/ucspi-unix/"
+SRC_URI="http://untroubled.org/ucspi-unix/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# We statically link bglibs.
+DEPEND=">=dev-libs/bglibs-1.106"
+# Block other unixcat installers. #480546
+RDEPEND="!net-analyzer/mk-livestatus"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gentoo-head.patch
+ epatch "${FILESDIR}"/${P}-include-sys_socket.h.patch
+ epatch "${FILESDIR}"/${P}-fix-parallel-build.patch
+}
+
+src_configure() {
+ local has_peercred
+ use kernel_linux && has_peercred="-DHASPEERCRED=1"
+
+ echo "$(tc-getCC) ${CPPFLAGS} ${CFLAGS} -I${SYSROOT}/usr/include/bglibs ${has_peercred} -D_GNU_SOURCE" > conf-cc
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -L${SYSROOT}/usr/$(get_libdir)/bglibs" > conf-ld
+}
+
+src_install() {
+ dobin unixserver unixclient unixcat
+ doman unixserver.1 unixclient.1
+ dodoc ANNOUNCEMENT NEWS PROTOCOL README TODO
+}