summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/files')
-rw-r--r--sys-apps/systemd/files/251-meson-0.64.patch26
-rw-r--r--sys-apps/systemd/files/251-revert-fortify-source-3-fix.patch40
2 files changed, 0 insertions, 66 deletions
diff --git a/sys-apps/systemd/files/251-meson-0.64.patch b/sys-apps/systemd/files/251-meson-0.64.patch
deleted file mode 100644
index 6cc200bbd87d..000000000000
--- a/sys-apps/systemd/files/251-meson-0.64.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From cddbc850270415a818aadabd71fe12dc0dddd508 Mon Sep 17 00:00:00 2001
-From: Jan Janssen <medhefgo@web.de>
-Date: Sun, 9 Oct 2022 17:16:12 +0200
-Subject: [PATCH] meson: Fix build with --optimization=plain
-
-Note that -O0 is deliberately filtered out as we have to compile with at
-least -O1 due to #24202.
-
-Fixes: #24323
----
- src/boot/efi/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
-index e0cd4ebad993..395386d3eda7 100644
---- a/src/boot/efi/meson.build
-+++ b/src/boot/efi/meson.build
-@@ -223,7 +223,7 @@ endif
- if get_option('debug') and get_option('mode') == 'developer'
- efi_cflags += ['-ggdb', '-DEFI_DEBUG']
- endif
--if get_option('optimization') != '0'
-+if get_option('optimization') in ['1', '2', '3', 's', 'g']
- efi_cflags += ['-O' + get_option('optimization')]
- endif
- if get_option('b_ndebug') == 'true' or (
diff --git a/sys-apps/systemd/files/251-revert-fortify-source-3-fix.patch b/sys-apps/systemd/files/251-revert-fortify-source-3-fix.patch
deleted file mode 100644
index bbe45f85dcf2..000000000000
--- a/sys-apps/systemd/files/251-revert-fortify-source-3-fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Sam James <sam@gentoo.org>
-Date: Tue, 24 May 2022 23:21:50 +0100
-Subject: [PATCH] Revert "Support -D_FORTIFY_SOURCE=3 by using
- __builtin_dynamic_object_size."
-
-Breaks Clang (even without F_S=3).
-
-This reverts commit 0bd292567a543d124cd303f7dd61169a209cae64.
-
-Bug: https://bugs.gentoo.org/841770
-Bug: https://github.com/systemd/systemd/issues/23150
---- a/src/basic/alloc-util.h
-+++ b/src/basic/alloc-util.h
-@@ -174,23 +174,13 @@ void* greedy_realloc0(void **p, size_t need, size_t size);
- * is compatible with _FORTIFY_SOURCES. If _FORTIFY_SOURCES is used many memory operations will take the
- * object size as returned by __builtin_object_size() into account. Hence, let's return the smaller size of
- * malloc_usable_size() and __builtin_object_size() here, so that we definitely operate in safe territory by
-- * both the compiler's and libc's standards. Note that _FORTIFY_SOURCES=3 handles also dynamically allocated
-- * objects and thus it's safer using __builtin_dynamic_object_size if _FORTIFY_SOURCES=3 is used (#22801).
-- * Moreover, when NULL is passed malloc_usable_size() is documented to return zero, and
-+ * both the compiler's and libc's standards. Note that __builtin_object_size() evaluates to SIZE_MAX if the
-+ * size cannot be determined, hence the MIN() expression should be safe with dynamically sized memory,
-+ * too. Moreover, when NULL is passed malloc_usable_size() is documented to return zero, and
- * __builtin_object_size() returns SIZE_MAX too, hence we also return a sensible value of 0 in this corner
- * case. */
--
--#if defined __has_builtin
--# if __has_builtin(__builtin_dynamic_object_size)
--# define MALLOC_SIZEOF_SAFE(x) \
-- MIN(malloc_usable_size(x), __builtin_dynamic_object_size(x, 0))
--# endif
--#endif
--
--#ifndef MALLOC_SIZEOF_SAFE
- #define MALLOC_SIZEOF_SAFE(x) \
- MIN(malloc_usable_size(x), __builtin_object_size(x, 0))
--#endif
-
- /* Inspired by ELEMENTSOF() but operates on malloc()'ed memory areas: typesafely returns the number of items
- * that fit into the specified memory block */