summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils/systemd-utils-252.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-utils/systemd-utils-252.6.ebuild')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-252.6.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-252.6.ebuild b/sys-apps/systemd-utils/systemd-utils-252.6.ebuild
index eb4b47dc0124..35fbaaa92fd2 100644
--- a/sys-apps/systemd-utils/systemd-utils-252.6.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-252.6.ebuild
@@ -6,7 +6,8 @@ PYTHON_COMPAT=( python3_{9..11} )
QA_PKGCONFIG_VERSION=$(ver_cut 1)
-inherit bash-completion-r1 flag-o-matic meson-multilib python-any-r1 toolchain-funcs udev usr-ldscript
+inherit bash-completion-r1 flag-o-matic linux-info meson-multilib python-any-r1
+inherit toolchain-funcs udev usr-ldscript
DESCRIPTION="Utilities split out from systemd for OpenRC users"
HOMEPAGE="https://systemd.io/"
@@ -105,6 +106,15 @@ python_check_deps() {
QA_EXECSTACK="usr/lib/systemd/boot/efi/*"
QA_FLAGS_IGNORED="usr/lib/systemd/boot/efi/.*"
+CONFIG_CHECK="~BLK_DEV_BSG ~DEVTMPFS ~!IDE ~INOTIFY_USER ~!SYSFS_DEPRECATED
+ ~!SYSFS_DEPRECATED_V2 ~SIGNALFD ~EPOLL ~FHANDLE ~NET ~UNIX"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]] && use udev; then
+ linux-info_pkg_setup
+ fi
+}
+
src_prepare() {
local PATCHES=(
)