summaryrefslogtreecommitdiff
path: root/sys-apps/sandbox/sandbox-2.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sandbox/sandbox-2.24.ebuild')
-rw-r--r--sys-apps/sandbox/sandbox-2.24.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-apps/sandbox/sandbox-2.24.ebuild b/sys-apps/sandbox/sandbox-2.24.ebuild
index 844b1e1fe4cc..fe66e82819fc 100644
--- a/sys-apps/sandbox/sandbox-2.24.ebuild
+++ b/sys-apps/sandbox/sandbox-2.24.ebuild
@@ -25,6 +25,15 @@ sandbox_death_notice() {
ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
}
+src_prepare() {
+ default
+
+ # sandbox uses `__asm__ (".symver "...` which does
+ # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
+ append-flags -fno-lto
+ append-ldflags -fno-lto
+}
+
multilib_src_configure() {
filter-lfs-flags #90228