summaryrefslogtreecommitdiff
path: root/sys-apps/rkflashtool/rkflashtool-6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rkflashtool/rkflashtool-6.1.ebuild')
-rw-r--r--sys-apps/rkflashtool/rkflashtool-6.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/rkflashtool/rkflashtool-6.1.ebuild b/sys-apps/rkflashtool/rkflashtool-6.1.ebuild
new file mode 100644
index 000000000000..8b4518ba94ab
--- /dev/null
+++ b/sys-apps/rkflashtool/rkflashtool-6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for flashing Rockchip devices"
+HOMEPAGE="https://sourceforge.net/projects/rkflashtool/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}/${P}-src.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S=${WORKDIR}/${P}-src
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ cp "${FILESDIR}"/${P}-missing-version.h version.h || die
+ sed -i -e "s/CC =/CC ?=/"\
+ -e "s/CFLAGS =/CFLAGS ?=/"\
+ -e "s/LDFLAGS =/LDFLAGS ?=/" Makefile || die
+ tc-export CC
+}
+
+src_install(){
+ dodoc README
+ dobin rkcrc rkflashtool rkmisc rkpad rkparameters rkparametersblock rkunpack rkunsign
+}