summaryrefslogtreecommitdiff
path: root/sys-apps/radeontool
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/radeontool')
-rw-r--r--sys-apps/radeontool/Manifest5
-rw-r--r--sys-apps/radeontool/metadata.xml15
-rw-r--r--sys-apps/radeontool/radeontool-1.6.3.ebuild24
-rw-r--r--sys-apps/radeontool/radeontool-1.6.3_p20181127.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/radeontool/Manifest b/sys-apps/radeontool/Manifest
new file mode 100644
index 000000000000..ca8618e572d5
--- /dev/null
+++ b/sys-apps/radeontool/Manifest
@@ -0,0 +1,5 @@
+DIST radeontool-1.6.3.tar.bz2 367487 BLAKE2B 0af4f7ce5f638b1ebfa191439f048bd3687ecec0085621b931890f07154fd40349c7d5eab57cb58fb75a6b0c9ebb687728332e3b72826f9b57b2272f67691eca SHA512 937ddf3e2b7dc35b9bc872d770b184303ac9e8199c0de6c17d187acfc5c398abc0cec2071c1af5ad16b0df2976418e06db8b1f90775fe59a8a80bdb3f8e2dca6
+DIST radeontool-1.6.3_p20181127.tar.gz 145939 BLAKE2B ba445095a45d0754c3d20fb45cb75754618d88c9ed23c988926323e9194ef3a8c6ea37c13880d6878750587e6de283a82789c98a6225e303edf7579a327261c2 SHA512 48779a1d7d4ceb79acaef4ba93074ee06b4ee0a02db42fbf1faa7cdc462e21e6c7450dd71c435788e54b99595e61f255154a672bfb8d76acb2d30f560ee6eca4
+EBUILD radeontool-1.6.3.ebuild 559 BLAKE2B 93c5569717865bf9dbf494161d5582297b35ac8be67353f5e34a7e77922b26439e8d70da543b9ce7a6cc6d6979a40dba55efe6a2617ee413a422a79f634146f6 SHA512 5a3e1d3c3f299032d8df4214cdce746e9e06e212322f44f8368877069c18b005cc88cbd434e1e1414aec967df2339966245b62efe15f95b269560dca2d918e44
+EBUILD radeontool-1.6.3_p20181127.ebuild 622 BLAKE2B 01b4ecc282f5e0a2683625faf4bf9e51423beec3a3d1df831dfb35f53a928213715df51dbbe94eabff2dd2e1573d81f761d9ce8f66c3b8ec09743013ead877af SHA512 4045d006d5b26397b40c80659fc92ad53936f3baae77b4ddf1df448593568806db79de43a8b411f5b9f541a4d6416133e59c7c937f84d53947427f7039a3602e
+MISC metadata.xml 495 BLAKE2B 17be5127a4b426e976b5634908bc5b05ce304f9f63c42f19be4492bce20ca315030531d8919277204869c0555ae4c24e74b207ff34e002886060f9811b377eff SHA512 adc8f558f969d79313893e30a90a838f99fdda22b9b47dd8dff992367b2a0383e4d49d75318dc9cd79ddbc3a2005d72c2c67ac4d16344299b348481df22773a9
diff --git a/sys-apps/radeontool/metadata.xml b/sys-apps/radeontool/metadata.xml
new file mode 100644
index 000000000000..af61ce3ac0f4
--- /dev/null
+++ b/sys-apps/radeontool/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Utility to control some functions of AMD/ATI Radeon chips:
+ - Turning on/off external DAC
+ - Turning on/off lcd panel backlight
+ - Turn on/off LCD scaling for resolution mismatch
+ - Dumping registers
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/radeontool/radeontool-1.6.3.ebuild b/sys-apps/radeontool/radeontool-1.6.3.ebuild
new file mode 100644
index 000000000000..edd777f7ac49
--- /dev/null
+++ b/sys-apps/radeontool/radeontool-1.6.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Manage the backlight, external video output and registers of ATI Radeon cards"
+
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/radeontool/"
+SRC_URI="https://people.freedesktop.org/~airlied/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+
+RDEPEND=">=x11-libs/libpciaccess-0.12.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ emake install DESTDIR="${D}"
+}
diff --git a/sys-apps/radeontool/radeontool-1.6.3_p20181127.ebuild b/sys-apps/radeontool/radeontool-1.6.3_p20181127.ebuild
new file mode 100644
index 000000000000..945498dc3d08
--- /dev/null
+++ b/sys-apps/radeontool/radeontool-1.6.3_p20181127.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="0a672473f583c6e4df3b1714d4af79653910811e"
+
+inherit autotools
+
+DESCRIPTION="Utility to get/set registers and controlling backlight on radeon based GPUs"
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/radeontool/"
+SRC_URI="https://dev.gentoo.org/~conikost/distfiles/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="x11-libs/libpciaccess"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}