summaryrefslogtreecommitdiff
path: root/sys-apps/pv/pv-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pv/pv-9999.ebuild')
-rw-r--r--sys-apps/pv/pv-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/pv/pv-9999.ebuild b/sys-apps/pv/pv-9999.ebuild
index 7d003e10536d..5e5b703403bd 100644
--- a/sys-apps/pv/pv-9999.ebuild
+++ b/sys-apps/pv/pv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,6 +38,13 @@ pkg_setup() {
src_prepare() {
default
+ # Valgrind isn't reliable within sandbox.
+ cat <<-EOF > tests/run-valgrind.sh || die
+ #!/bin/sh
+ exit 77
+ EOF
+ chmod +x tests/run-valgrind.sh || Die
+
[[ ${PV} == 9999 ]] && eautoreconf
}