summaryrefslogtreecommitdiff
path: root/sys-apps/proot/proot-5.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/proot/proot-5.4.0.ebuild')
-rw-r--r--sys-apps/proot/proot-5.4.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/proot/proot-5.4.0.ebuild b/sys-apps/proot/proot-5.4.0.ebuild
index e7fd0dc982cc..1ebb99466a25 100644
--- a/sys-apps/proot/proot-5.4.0.ebuild
+++ b/sys-apps/proot/proot-5.4.0.ebuild
@@ -42,7 +42,14 @@ src_compile() {
CHECK_VERSION="true" \
CAREBUILDENV="ok" \
proot $(use care && echo "care")
- emake -C doc SUFFIX=".py" proot/man.1
+
+ # Docutils >=0.21 dropped .py console scripts
+ # bug #930449
+ if has_version ">=dev-python/docutils-0.21" ; then
+ emake -C doc proot/man.1
+ else
+ emake -C doc SUFFIX=".py" proot/man.1
+ fi
}
src_install() {