summaryrefslogtreecommitdiff
path: root/sys-apps/proot/proot-5.1.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/proot/proot-5.1.0-r2.ebuild')
-rw-r--r--sys-apps/proot/proot-5.1.0-r2.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/sys-apps/proot/proot-5.1.0-r2.ebuild b/sys-apps/proot/proot-5.1.0-r2.ebuild
index ac2eea07dbf7..32cc49074395 100644
--- a/sys-apps/proot/proot-5.1.0-r2.ebuild
+++ b/sys-apps/proot/proot-5.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,20 +6,15 @@ MY_PN="PRoot"
inherit eutils toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/proot-me/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
DESCRIPTION="User-space implementation of chroot, mount --bind, and binfmt_misc"
HOMEPAGE="https://proot-me.github.io"
LICENSE="GPL-2"
SLOT="0"
-IUSE="care static test"
+IUSE="care test"
RDEPEND="care? ( app-arch/libarchive:0= )
sys-libs/talloc"
@@ -38,11 +33,6 @@ PATCHES=(
"${FILESDIR}/${PN}-5.1.0-loader.patch"
)
-src_prepare() {
- default
- use static && append-ldflags -static
-}
-
src_compile() {
# build the proot and care targets
emake -C src V=1 \