summaryrefslogtreecommitdiff
path: root/sys-apps/portage
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/portage')
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-9999.ebuild22
2 files changed, 10 insertions, 14 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index d6d577271be6..5786c6337a3d 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -7,5 +7,5 @@ DIST portage-3.0.63.tar.bz2 1187961 BLAKE2B 10523150b0eabac97309004c57356c40fa94
EBUILD portage-3.0.59-r1.ebuild 6919 BLAKE2B 42d9b40cd255004ae6e3e598940717296163e500434a8c2bdf08b280915aecf8dc9d5f3b6d9eb5dc09c8718f689b459ec6a1f5df03187935d17d447f8b2e0f25 SHA512 59cfb6566b72a82cf81503b40b3ad73bb1616c39a6957d14681c55b53a60b662eb5330b7021d6c860212c4e583c4ed67e64ff5a55738f2f8f1a22d5cf4442e03
EBUILD portage-3.0.61-r1.ebuild 6919 BLAKE2B 42d9b40cd255004ae6e3e598940717296163e500434a8c2bdf08b280915aecf8dc9d5f3b6d9eb5dc09c8718f689b459ec6a1f5df03187935d17d447f8b2e0f25 SHA512 59cfb6566b72a82cf81503b40b3ad73bb1616c39a6957d14681c55b53a60b662eb5330b7021d6c860212c4e583c4ed67e64ff5a55738f2f8f1a22d5cf4442e03
EBUILD portage-3.0.63.ebuild 6927 BLAKE2B e6ea3a331b29c53e5dbc2240db2923a75f27ac77533c3dcf12eec266d2418deb5939887c112460fdb5e8c67681e6a134109065fdf32b2ec66573edf5bac74515 SHA512 5443ee6ba6d1c1b340f87908811becdc1821ec1410aa2e9eb860268400f66fa26d7d7cc8216c93afcb04a4d7b41360506a8e3c54412b95154576a988933cb89e
-EBUILD portage-9999.ebuild 6927 BLAKE2B e6ea3a331b29c53e5dbc2240db2923a75f27ac77533c3dcf12eec266d2418deb5939887c112460fdb5e8c67681e6a134109065fdf32b2ec66573edf5bac74515 SHA512 5443ee6ba6d1c1b340f87908811becdc1821ec1410aa2e9eb860268400f66fa26d7d7cc8216c93afcb04a4d7b41360506a8e3c54412b95154576a988933cb89e
+EBUILD portage-9999.ebuild 6790 BLAKE2B c0c4b0323ecf461cdd38831f8644944803b3c3cc653e11b7ed88ac4495f99ccf6fffc170d1bf41daffa60e5d8d262766a3e9641eac3f106f2dd866b6354722fd SHA512 73def9620f9e55157d298d89064cf7c7011ed0320fe1a2fb597b5ad74cf2ff2696a60ef1a89780883aecd98964bc559ed4d91d2d73f37082795885dc8181f169
MISC metadata.xml 1539 BLAKE2B 0efa1ae365449d6593909046c32158a9f6755aa9252c34ae00eb866dd29a0b6a5c2e7a4af9293d0f87c4dd9231132fc5361acb0818fb6beff6dd6fbbdc6f409b SHA512 675f5baa1b3079592e3930b11ca18f324e27c42b5515f9ae815a26e53a465640fa6e9c4069df0e2121932b9f1cc73f2c9469c1529728f3c5ed5c3e687743ac0d
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 834b9af7a549..ea323e5a917c 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE='bzip2(+),threads(+)'
TMPFILES_OPTIONAL=1
-inherit meson linux-info multiprocessing python-r1 tmpfiles
+inherit meson linux-info python-r1 tmpfiles
DESCRIPTION="The package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -35,6 +35,7 @@ RESTRICT="!test? ( test )"
# >=meson-1.2.1-r1 for bug #912051
BDEPEND="
${PYTHON_DEPS}
+ >=app-arch/tar-1.27
>=dev-build/meson-1.2.1-r1
|| (
>=dev-build/meson-1.3.0-r1
@@ -43,15 +44,6 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools[${PYTHON_USEDEP}]
' python3_12)
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-DEPEND="
- ${PYTHON_DEPS}
- >=app-arch/tar-1.27
- dev-lang/python-exec:2
>=sys-apps/sed-4.0.5
sys-devel/patch
!build? ( $(python_gen_impl_dep 'ssl(+)') )
@@ -63,6 +55,10 @@ DEPEND="
~app-text/docbook-xml-dtd-4.4
app-text/xmlto
)
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
"
# Require sandbox-2.2 for bug #288863.
# For whirlpool hash, require python[ssl] (bug #425046).
@@ -164,9 +160,9 @@ src_compile() {
}
src_test() {
- local -x PYTEST_ADDOPTS="-vv -ra -l -o console_output_style=count -n $(makeopts_jobs) --dist=worksteal"
-
- python_foreach_impl meson_src_test --no-rebuild --verbose
+ local EPYTEST_XDIST=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ python_foreach_impl epytest
}
src_install() {