summaryrefslogtreecommitdiff
path: root/sys-apps/polychromatic/polychromatic-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/polychromatic/polychromatic-9999.ebuild')
-rw-r--r--sys-apps/polychromatic/polychromatic-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-apps/polychromatic/polychromatic-9999.ebuild b/sys-apps/polychromatic/polychromatic-9999.ebuild
index 7baaa20d6a71..19e9c50db521 100644
--- a/sys-apps/polychromatic/polychromatic-9999.ebuild
+++ b/sys-apps/polychromatic/polychromatic-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit meson python-single-r1 readme.gentoo-r1 xdg
@@ -11,12 +11,14 @@ DESCRIPTION="RGB lighting management software for GNU/Linux powered by OpenRazer
HOMEPAGE="https://polychromatic.app/
https://github.com/polychromatic/polychromatic/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64"
fi
@@ -28,8 +30,8 @@ RDEPEND="
${PYTHON_DEPS}
>=x11-libs/gtk+-3.20:3[introspection]
$(python_gen_cond_dep '
- dev-python/PyQt5[svg,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/PyQt6-WebEngine[${PYTHON_USEDEP}]
+ dev-python/PyQt6[svg,${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/colour[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
@@ -59,8 +61,8 @@ src_install() {
# Do not force polychromatic to autostart on session login.
# Move it into /usr/share/polychromatic and treat it as an example file
# that could be installed into user's ~/.config/autostart/ directory.
- mv "${ED}"/etc/xdg/autostart/${PN}-autostart.desktop \
- "${ED}"/usr/share/${PN}/${PN}-autostart.desktop || die
+ mv "${ED}/etc/xdg/autostart/${PN}-autostart.desktop" \
+ "${ED}/usr/share/${PN}/${PN}-autostart.desktop" || die
}
pkg_postinst() {