summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild')
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild39
1 files changed, 16 insertions, 23 deletions
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild
index 87907e6517d5..602e0cb56e08 100644
--- a/sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.25-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit python-single-r1 systemd udev user multilib-minimal
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit python-single-r1 systemd udev multilib-minimal
DESCRIPTION="PC/SC Architecture smartcard middleware library"
-HOMEPAGE="https://pcsclite.apdu.fr/"
+HOMEPAGE="https://pcsclite.apdu.fr https://github.com/LudovicRousseau/PCSC"
SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
@@ -15,27 +16,28 @@ SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
# upstream.
LICENSE="BSD ISC MIT GPL-3+ GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
# This is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="python libusb policykit selinux systemd +udev"
+IUSE="libusb policykit selinux systemd +udev"
-REQUIRED_USE="^^ ( udev libusb )
- python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="^^ ( udev libusb ) ${PYTHON_REQUIRED_USE}"
# No dependencies need the MULTILIB_DEPS because the libraries are actually
# standalone, the deps are only needed for the daemon itself.
DEPEND="libusb? ( virtual/libusb:1 )
udev? ( virtual/udev )
policykit? ( >=sys-auth/polkit-0.111 )
- python? ( ${PYTHON_DEPS} )"
+ acct-group/openct
+ acct-group/pcscd
+ acct-user/pcscd
+ ${PYTHON_DEPS}"
+
RDEPEND="${DEPEND}
- !<app-crypt/ccid-1.4.1-r1
- !<sys-apps/baselayout-2
- !<sys-apps/openrc-0.11.8
selinux? ( sec-policy/selinux-pcscd )"
+
BDEPEND="virtual/pkgconfig"
PATCHES=(
@@ -45,10 +47,7 @@ PATCHES=(
DOCS=( AUTHORS HELP README SECURITY ChangeLog )
pkg_setup() {
- use python && python-single-r1_pkg_setup
- enewgroup openct # make sure it exists
- enewgroup pcscd
- enewuser pcscd -1 -1 /run/pcscd pcscd,openct
+ python-single-r1_pkg_setup
}
multilib_src_configure() {
@@ -76,13 +75,7 @@ multilib_src_install_all() {
newins "${FILESDIR}"/99-pcscd-hotplug-r1.rules 99-pcscd-hotplug.rules
fi
- for f in "${ED}/usr/bin/pcsc-spy"; do
- if use python; then
- python_fix_shebang "${f}"
- else
- rm "${f}" || die
- fi
- done
+ python_fix_shebang "${ED}"/usr/bin/pcsc-spy
}
pkg_postinst() {