summaryrefslogtreecommitdiff
path: root/sys-apps/openrc
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/Manifest2
-rw-r--r--sys-apps/openrc/openrc-0.43.4.ebuild184
2 files changed, 186 insertions, 0 deletions
diff --git a/sys-apps/openrc/Manifest b/sys-apps/openrc/Manifest
index 9cd33b9de98f..e37ef3799672 100644
--- a/sys-apps/openrc/Manifest
+++ b/sys-apps/openrc/Manifest
@@ -3,7 +3,9 @@ AUX openrc.logrotate 43 BLAKE2B 0587cd211767937fd6273e6b159271490443a94d80a54b5a
AUX start-stop-daemon.pam 63 BLAKE2B df39a1a12fe09dbbc0746eac67035d9e6d4a63323f6c937ef3888c70787354128e415b3c1c8bccccec0c987b3e789711cd1ddaba55e9b53a7f67b332c4ca9d5b SHA512 85cf440611b8f87f51bf24bdd9fa03639a75b950f00096d81b8826c21ae85ff9784b8c56b8ddb482e70f08bce933d4561b30750346d51fb2cef3be34acc065cb
DIST openrc-0.42.1.tar.gz 242848 BLAKE2B 381f52552c13afbbcf45456fe71078bacf9182adfd67c97394093986977f5e8262d8a3c64219501745575a5210f525afe9fccee72f7625485a9f575108baa369 SHA512 579b9bfbb151b945a364a2c12b037d2e15991820ca99a07ac18e9bdc50074e67fbf0dcf9865aa4deabe2bf82092e4623be51c9e0b4014384951e0a92ac1e7646
DIST openrc-0.43.3.tar.gz 240431 BLAKE2B 4e7326e2cb87fbb9101b616f0ad5a955f38f387e9d940a0ae1d00a8b48e7733411b3f0a4bb70bfc6a63cb4769354d7836cb4accd695b73f601d9b6bab8b8a8ea SHA512 a6b0a3b7eba7624ed00cb33253cec71059b9af194f3828eb7417f9faba551ecdff7c1e1b5132772969a9c868ff60a92378b28e56e54edfe8e0f4e143aa43b8c5
+DIST openrc-0.43.4.tar.gz 241876 BLAKE2B c50cefb079a63c9a682f37244f84ea96e8428d6ddbfd5af7f6e03b5abf206158426d2b7af2b0e9354cf50178f59b6179a8698826b3b9af9086904c17f88bee56 SHA512 705ecb458ffbfcf143d53c17e7f01e0e2cd5450d43b7b0ddf1460f9ef684114d4bcd6ba50ef1510920db89c1cdbf13f954b744ef16a0e881650377ff7a254b55
EBUILD openrc-0.42.1-r1.ebuild 5471 BLAKE2B a3749af382add50151e08b679ac8548f4a229784de8ca796c1c5d113ea190c42980e18ad8bd5598fee43a049538e4d806398aabe7bdfa27a79361529bfdd5445 SHA512 638ff01c5c1de288e462790dbc9c5801b326768051933a96a9338278b36208a39934be4e7b9605ca286e30baa9e83dab58075e50ee9de112ce4e117cc0767b97
EBUILD openrc-0.43.3.ebuild 5035 BLAKE2B c6fb18f7ce7aff1b5ee7aa242b0b578cc712c71a8cb300fc9070b41fcc511eec632ac9a75896d3c20dd553b0fe9839c7c409382a5c801a6f16eae03e60f64b2f SHA512 cdd691b9a30a2fc8bd064a11bd37d4c93893a26282fb5fa17c177f90c6101eed1d46031138ba3443c8bf28e98768ca8e7cca597da3c9a20e0b3af8d9ea630906
+EBUILD openrc-0.43.4.ebuild 5013 BLAKE2B eba47aae6e1d07c2ccd925f2e380268a6ab96aec37e245b3ccf0474d30fc19811a5f45c610a6fd68760a4695f48040733aa524f41c86a9149bcdbb97195ba4a0 SHA512 24970d1219d2fc2c93ecd6ddc22200af0a3e70decb506f06ffd2f3be15a7b3a37398e150f26d6c2477b59f3ece72babf61056ddd3c6e86233b7576f081460cd3
EBUILD openrc-9999.ebuild 5013 BLAKE2B eba47aae6e1d07c2ccd925f2e380268a6ab96aec37e245b3ccf0474d30fc19811a5f45c610a6fd68760a4695f48040733aa524f41c86a9149bcdbb97195ba4a0 SHA512 24970d1219d2fc2c93ecd6ddc22200af0a3e70decb506f06ffd2f3be15a7b3a37398e150f26d6c2477b59f3ece72babf61056ddd3c6e86233b7576f081460cd3
MISC metadata.xml 706 BLAKE2B 1d6a4937d577fff7db7fd64617328ca49faccaa61749adabc411a215960ee06c1af32499be697921012eee34f5c680295e46f545099f06393965a17c0d0d034d SHA512 d5d669cdcf8707689c855cab678031c6e9b1e33e4b931c7d80bbe2ad442aedabef718018466f0cb15bd8a329292a0de844935f9332611f3fb334b57d14aa39c1
diff --git a/sys-apps/openrc/openrc-0.43.4.ebuild b/sys-apps/openrc/openrc-0.43.4.ebuild
new file mode 100644
index 000000000000..1b2b297f3023
--- /dev/null
+++ b/sys-apps/openrc/openrc-0.43.4.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic pam toolchain-funcs
+
+DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
+HOMEPAGE="https://github.com/openrc/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/OpenRC/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="audit bash debug ncurses pam newnet prefix +netifrc selinux sysv-utils unicode"
+
+COMMON_DEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ pam? ( sys-libs/pam )
+ audit? ( sys-process/audit )
+ sys-process/psmisc
+ !<sys-process/procps-3.3.9-r2
+ selinux? (
+ sys-apps/policycoreutils
+ >=sys-libs/libselinux-2.6
+ )
+ !<sys-apps/baselayout-2.1-r1
+ !<sys-fs/udev-init-scripts-27"
+DEPEND="${COMMON_DEPEND}
+ virtual/os-headers
+ ncurses? ( virtual/pkgconfig )"
+RDEPEND="${COMMON_DEPEND}
+ bash? ( app-shells/bash )
+ !prefix? (
+ sysv-utils? (
+ !sys-apps/systemd[sysv-utils(-)]
+ !sys-apps/sysvinit
+ )
+ !sysv-utils? ( >=sys-apps/sysvinit-2.86-r6[selinux?] )
+ virtual/tmpfiles
+ )
+ selinux? (
+ >=sec-policy/selinux-base-policy-2.20170204-r4
+ >=sec-policy/selinux-openrc-2.20170204-r4
+ )
+ !<app-shells/gentoo-bashcomp-20180302
+ !<app-shells/gentoo-zsh-completions-20180228
+"
+
+PDEPEND="netifrc? ( net-misc/netifrc )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/gitver.mk || die
+ fi
+}
+
+src_compile() {
+ MAKE_ARGS="${MAKE_ARGS}
+ LIBNAME=$(get_libdir)
+ LIBDIR=${EPREFIX}/$(get_libdir)
+ LIBEXECDIR=${EPREFIX}/lib/rc
+ MKBASHCOMP=yes
+ MKNET=$(usex newnet)
+ MKSELINUX=$(usex selinux)
+ MKSYSVINIT=$(usex sysv-utils)
+ MKAUDIT=$(usex audit)
+ MKPAM=$(usev pam)
+ MKSTATICLIBS=no
+ MKZSHCOMP=yes
+ OS=Linux
+ SH=$(usex bash /bin/bash /bin/sh)"
+
+ use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
+export BRANDING="Gentoo Linux"
+ export DEBUG=$(usev debug)
+ export MKTERMCAP=$(usev ncurses)
+
+ tc-export CC AR RANLIB
+ emake ${MAKE_ARGS}
+}
+
+# set_config <file> <option name> <yes value> <no value> test
+# a value of "#" will just comment out the option
+set_config() {
+ local file="${ED}/$1" var=$2 val com
+ eval "${@:5}" && val=$3 || val=$4
+ [[ ${val} == "#" ]] && com="#" && val='\2'
+ sed -i -r -e "/^#?${var}=/{s:=([\"'])?([^ ]*)\1?:=\1${val}\1:;s:^#?:${com}:}" "${file}"
+}
+
+set_config_yes_no() {
+ set_config "$1" "$2" YES NO "${@:3}"
+}
+
+src_install() {
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
+
+ keepdir /lib/rc/tmp
+
+ # Setup unicode defaults for silly unicode users
+ set_config_yes_no /etc/rc.conf unicode use unicode
+
+ # Cater to the norm
+ set_config_yes_no /etc/conf.d/keymaps windowkeys '(' use x86 '||' use amd64 ')'
+
+ # On HPPA, do not run consolefont by default (bug #222889)
+ if use hppa; then
+ rm -f "${ED}"/etc/runlevels/boot/consolefont
+ fi
+
+ # Support for logfile rotation
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/openrc.logrotate openrc
+
+ if use pam; then
+ # install gentoo pam.d files
+ newpamd "${FILESDIR}"/start-stop-daemon.pam start-stop-daemon
+ newpamd "${FILESDIR}"/start-stop-daemon.pam supervise-daemon
+ fi
+
+ # install documentation
+ dodoc ChangeLog *.md
+ if use newnet; then
+ dodoc README.newnet
+ fi
+}
+
+pkg_preinst() {
+ # avoid default thrashing in conf.d files when possible #295406
+ if [[ -e "${EROOT}"/etc/conf.d/hostname ]] ; then
+ (
+ unset hostname HOSTNAME
+ source "${EROOT}"/etc/conf.d/hostname
+ : ${hostname:=${HOSTNAME}}
+ [[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
+ )
+ fi
+
+ # set default interactive shell to sulogin if it exists
+ set_config /etc/rc.conf rc_shell /sbin/sulogin "#" test -e /sbin/sulogin
+ return 0
+}
+
+pkg_postinst() {
+ if use hppa; then
+ elog "Setting the console font does not work on all HPPA consoles."
+ elog "You can still enable it by running:"
+ elog "# rc-update add consolefont boot"
+ fi
+
+ # Added for 0.35.
+ if [[ ! -h "${EROOT}"/lib ]]; then
+ if [[ -d "${EROOT}/$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}/$(get_libdir)/rc" "${EROOT}"/lib
+ fi
+ fi
+
+ if ! use newnet && ! use netifrc; then
+ ewarn "You have emerged OpenRc without network support. This"
+ ewarn "means you need to SET UP a network manager such as"
+ ewarn " net-misc/netifrc, net-misc/dhcpcd, net-misc/connman,"
+ ewarn " net-misc/NetworkManager, or net-vpn/badvpn."
+ ewarn "Or, you have the option of emerging openrc with the newnet"
+ ewarn "use flag and configuring /etc/conf.d/network and"
+ ewarn "/etc/conf.d/staticroute if you only use static interfaces."
+ ewarn
+ fi
+
+ if use newnet && [ ! -e "${EROOT}"/etc/runlevels/boot/network ]; then
+ ewarn "Please add the network service to your boot runlevel"
+ ewarn "as soon as possible. Not doing so could leave you with a system"
+ ewarn "without networking."
+ ewarn
+ fi
+}