summaryrefslogtreecommitdiff
path: root/sys-apps/mtree/mtree-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mtree/mtree-1.0.4.ebuild')
-rw-r--r--sys-apps/mtree/mtree-1.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/mtree/mtree-1.0.4.ebuild b/sys-apps/mtree/mtree-1.0.4.ebuild
new file mode 100644
index 000000000000..151c42b2c734
--- /dev/null
+++ b/sys-apps/mtree/mtree-1.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Directory hierarchy mapping tool from FreeBSD"
+HOMEPAGE="https://github.com/archiecobbs/mtree-port"
+SRC_URI="https://github.com/archiecobbs/mtree-port/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-port-${PV}"
+
+src_prepare() {
+ default
+ # don't install unneeded docs
+ sed -i '/doc_DATA=/d' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # avoid conflict with app-arch/libarchive
+ rm "${ED%/}/usr/share/man/man5/mtree.5"
+}