summaryrefslogtreecommitdiff
path: root/sys-apps/locale-gen/locale-gen-2.23.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/locale-gen/locale-gen-2.23.ebuild')
-rw-r--r--sys-apps/locale-gen/locale-gen-2.23.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/locale-gen/locale-gen-2.23.ebuild b/sys-apps/locale-gen/locale-gen-2.23.ebuild
new file mode 100644
index 000000000000..4b6dadbfa5d4
--- /dev/null
+++ b/sys-apps/locale-gen/locale-gen-2.23.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit prefix
+
+DESCRIPTION="Generate locales based upon the config file /etc/locale.gen"
+HOMEPAGE="https://gitweb.gentoo.org/proj/locale-gen.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/locale-gen.git/snapshot/${P}.tar.bz2"
+
+# Totally unclear what the license is. Following here the statement
+# in the Debian file that the tools accompanying glibc are GPL-2+
+LICENSE="GPL-2+"
+
+SLOT="0"
+#KEYWORDS="~amd64"
+
+RDEPEND="
+ app-alternatives/awk
+ app-arch/gzip
+ sys-apps/gentoo-functions
+ sys-apps/grep
+ >=sys-libs/glibc-2.38
+ !<sys-libs/glibc-2.38
+"
+DEPEND=""
+
+src_prepare() {
+ default
+ eprefixify locale-gen
+}
+
+src_install() {
+ dosbin locale-gen
+ doman *.[0-8]
+ insinto /etc
+ doins locale.gen
+ keepdir /usr/lib/locale
+}