summaryrefslogtreecommitdiff
path: root/sys-apps/kbd
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest2
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild30
2 files changed, 19 insertions, 13 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 6f81a7cf5183..a68e137d96a5 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -6,5 +6,5 @@ DIST kbd-2.0.4.tar.xz 1031864 BLAKE2B 10c2bded89befda1f1d7ab199796e082a4e3b2333c
EBUILD kbd-1.15.5-r1.ebuild 1040 BLAKE2B b0a2cd71950581a1a7bdcf75b4aa29787ef9b5e22cb5e482c885733be799b02b0d4433fd6a47a50a54efecfc0596d98a9cc30f42e67af9fd831414280f2a2039 SHA512 aea6c477a1527e5f38419c2356bf97e52bbfc9473919b182392d1a0bff96af9d0912b2cd132e4d015889a55e9b3a8613937b1d8e0d847b0d794596309ddc9ceb
EBUILD kbd-2.0.3.ebuild 1360 BLAKE2B 3d285f5816f752701e123fc4441e9991dceb0d80eb9ee5f84f87f4cdb140306d23f7e7d40abca7df0ce372ec79ad55996e37b0fa6dc0bb67030fc5b8fde00cde SHA512 358c6679bea2e0270159fa07a4578f75c8356d1774e6d9f8def085f94225ac733a3e2e9a9e552485e15d763a0835256a9ea238893dd0280b4435f724cf23edba
EBUILD kbd-2.0.4.ebuild 1353 BLAKE2B 04d05d62ec1e81288d8ed6c1edac17e8e0991bc1147945459493e4b4b7b31a8e47001f8b223c1594f819249428ca9dfa86b1fa91a08a1213d00fbc7069c871aa SHA512 773f75e85efec50dff3a3e1778ba78da3e60b8d3715388b4cc7b4cc6d6f7a8b15e107b99d3027ecf3c1234346ef0c09e6247c8e161c60b6ad1bdee19ec248439
-EBUILD kbd-9999.ebuild 1342 BLAKE2B 0fc684dfac11a57b1833ff835e932414626db000c91151cb36b97a2122fb465882ceab8d2c602d2ea1d96d749f63ffc14fb1a72ac695fcf93311db7d74c666e0 SHA512 93b2ea0888ed50fb4f1bffb063797621767cf09f001361afab2c9c3acda28092ccde61c61f7e740880471c5626fa2c6700d1ada4c63c55d75257c029af8b18e6
+EBUILD kbd-9999.ebuild 1412 BLAKE2B e0ed21760db01f1b81ed5b41225edb1fbc2b7638875fb663b7b4a70edc7a0f8dff5d02aaa289be61d2276035ec56589a4eebd2a3f9bdf2bdcf26a700b8a0020e SHA512 73150ecc4977e06aab03c867d97a9e78cfc749b1261fb099347072a4b07ff6a0fbdfa868c2262ed6d1c8ae2e994c137906aaf70e9a83919ba27025a600594fb7
MISC metadata.xml 321 BLAKE2B 608f4a02a31f6c1590d7c237516a00cefa06f641febb7b479b7b0a276e9b59c0b7a88bbc6f4bdaca942ae83b85ebad6c6e84097916315eb985ebc2d98a70b171 SHA512 f00b80d88f4647f210c28f95f8dc81fc8ff3bcbe74e6429e9d5dd92e57588297aafee968b8a3cad2db3b2010fd9ebc400975ca59ffcd62370afa799745dda641
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index 139d12639fd3..df8a5adeb6c8 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
SCM=""
if [[ ${PV} == "9999" ]] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://git.kernel.org/cgit/linux/kernel/git/legion/kbd.git"
+ SCM="autotools git-r3"
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
EGIT_BRANCH="master"
else
SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
-inherit autotools eutils ${SCM}
+inherit eutils ${SCM}
DESCRIPTION="Keyboard and console utilities"
HOMEPAGE="http://kbd-project.org/"
@@ -22,7 +22,8 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
-RDEPEND="pam? ( virtual/pam )"
+RDEPEND="pam? ( virtual/pam )
+ app-arch/gzip"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-libs/check )"
@@ -44,18 +45,23 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.0-tests.patch
- eautoreconf
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
}
src_configure() {
- econf \
- $(use_enable nls) \
- $(use_enable pam vlock) \
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable pam vlock)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- dohtml docs/doc/*.html
+ docinto html
+ dodoc docs/doc/*.html
}