summaryrefslogtreecommitdiff
path: root/sys-apps/init-system-helpers
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/init-system-helpers')
-rw-r--r--sys-apps/init-system-helpers/Manifest2
-rw-r--r--sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/init-system-helpers/Manifest b/sys-apps/init-system-helpers/Manifest
index eb96f22ea015..80d236401cbe 100644
--- a/sys-apps/init-system-helpers/Manifest
+++ b/sys-apps/init-system-helpers/Manifest
@@ -1,4 +1,6 @@
AUX revert-openrc-management.patch 929 BLAKE2B 58d0fa10956bf930c176a84573a5b780fa4bcb87f6df180a179f0cbac93ede8f2147fe620007f68e563ec4a3e86228efacc2ca33dce135c5d1fa1d639cd7fc82 SHA512 ba046ae948f93d0d861fd70637c2b1acaa37ba3ef225453162eb19ae854504f518a1024c484118b86bde3f57099bb7a44d46e3765bca4b1766bf2565c990f356
DIST init-system-helpers_1.60.tar.xz 40584 BLAKE2B ad21a65ef3c4bcec16b14fc4db890fb7f83df625d1038fe217c20e9391404914df189ae31506b9bbef0442cdd333f46bd9c4d9009b7d671d9ae2deb6b05eee8e SHA512 3739613fa8afa1fa6032f47f8cec67c526171987a7d1eae31d479db9cc1e49ae3cd397a858130c17680d62becb9c6499bd1da1268e9ed25b044337ab69f0dd88
+DIST init-system-helpers_1.66.tar.xz 44976 BLAKE2B e97d4483c73e7d5c310598eb75d77972f5334ef09708166f3bacb46e4e4495c7f7b2a905e70221180fbcd0524312c6b0962bf55a165092dccc839218f2fc46c5 SHA512 22c8c7f6483de6e95750a48d55b540478de9cd8ed23e806359b30e19528313cdc03f119b076182575ec3e06f76d628a95b0b9568be2d03fcbba278617661c93e
EBUILD init-system-helpers-1.60.ebuild 987 BLAKE2B 2ea41b13a73770160a95dbfd8eb62cf6a2b547f4edb88d0104db999879711da8fdd95b08f38f543c7091214f891d109d0d2c9ae07ff75152c7414d0e79c72627 SHA512 be2d5d8bd04113f87d4c659e0682a0f5584e38c286b5f5738f63fd480df57ff024fd527906513e9b7d6a289bd064b9dba74358b5e2abddb5591a8ba4fd833196
+EBUILD init-system-helpers-1.66.ebuild 1014 BLAKE2B 2004009f04a4ca24f4bf2b0390ce651c673593cc759c4286f93755a2db9f76f2c6ceda11bf42403f6633602c7d2d31bb5aff19624b347dff1e719db963a5fc25 SHA512 5da8541b682a1033e0954f72397dc771d5578738733981819888c25b30533f154996e927f651b53472c3896557a0a6dc54c9bace45e6a81e07bd857db32b5b6e
MISC metadata.xml 192 BLAKE2B fef49cb9e1dda8063c379e650d4897670410d2c0641f469b8a200d5e7ec8d3f505e692277d03b583790cb1340ece9c2e8f7e7c9ff5080d42a2e0ef3fc7138a44 SHA512 bece454b8da734c7a28ce25f8080b3fca56332e57cde854c50f0b884ba3836f1af7782a1ee9f63e6aeff4830e2bca71c5c466471fc82eee75339565aab6495d5
diff --git a/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild b/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild
new file mode 100644
index 000000000000..16d0b3cc65fe
--- /dev/null
+++ b/sys-apps/init-system-helpers/init-system-helpers-1.66.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Helper scripts useful for both OpenRC and systemd"
+HOMEPAGE="https://packages.debian.org/sid/init-system-helpers"
+# git repo: https://anonscm.debian.org/git/collab-maint/init-system-helpers.git
+SRC_URI="http://http.debian.net/debian/pool/main/i/${PN}/${PN}_${PV}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND=">=dev-python/docutils-0.21.2"
+RDEPEND="!<sys-apps/openrc-0.33"
+
+PATCHES=(
+ "${FILESDIR}/revert-openrc-management.patch"
+)
+
+src_install() {
+ # We only care about 'service' script/manpage:
+ exeinto /sbin/
+ doexe script/service
+
+ rst2man man8/service.rst > man8/service.8 || die "Failed to generate man page"
+
+ # FIXME: need to patch to remove *rc.d references, which we don't ship
+ # And should probably add a list of supported options (e.g., start/stop/etc.)
+ doman man8/service.8
+}