summaryrefslogtreecommitdiff
path: root/sys-apps/groff/groff-1.22.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/groff/groff-1.22.4.ebuild')
-rw-r--r--sys-apps/groff/groff-1.22.4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/groff/groff-1.22.4.ebuild b/sys-apps/groff/groff-1.22.4.ebuild
index 67b0f18455e9..8ec07c8c1ad7 100644
--- a/sys-apps/groff/groff-1.22.4.ebuild
+++ b/sys-apps/groff/groff-1.22.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,7 +28,8 @@ RDEPEND="
x11-libs/libICE
)"
DEPEND="${RDEPEND}
- dev-lang/perl"
+ dev-lang/perl
+ sys-apps/texinfo"
DOCS=( BUG-REPORT ChangeLog MORE.STUFF NEWS PROBLEMS PROJECTS README TODO )
@@ -42,9 +43,9 @@ src_prepare() {
default
# honor Gentoo's docdir
- sed -i -e '/^docdir=/s/^/#/' \
- Makefile.am \
- || die "failed to modify Makefile.am"
+ sed -i -e "s|^docdir =.*|docdir = \"${EPREFIX%/}/usr/share/doc/${PF}\"|g" \
+ Makefile.in \
+ || die "failed to modify Makefile.in"
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
@@ -73,7 +74,6 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--with-appresdir="${EPREFIX%/}"/usr/share/X11/app-defaults
- --docdir="${EPREFIX%/}"/usr/share/doc/${PF}
$(use_with X x)
)
econf "${myeconfargs[@]}"