summaryrefslogtreecommitdiff
path: root/sys-apps/goawk/goawk-1.26.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/goawk/goawk-1.26.0.ebuild')
-rw-r--r--sys-apps/goawk/goawk-1.26.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/goawk/goawk-1.26.0.ebuild b/sys-apps/goawk/goawk-1.26.0.ebuild
new file mode 100644
index 000000000000..9b774e46f9c9
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.26.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND=">=dev-lang/go-1.16"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}