summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index 0d5b07883d97..bb66dd8ea452 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd
+inherit systemd udev
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
@@ -35,6 +35,7 @@ src_configure() {
local myconf=(
--with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
--with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ udevdir="${EPREFIX}$(get_udevdir)"
)
econf "${myconf[@]}"
}