summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild
deleted file mode 100644
index 8df3a1e88bad..000000000000
--- a/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2014-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
-else
- SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-inherit meson
-
-DESCRIPTION="Base functions required by all Gentoo systems"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
-
-LICENSE="GPL-2 public-domain"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Specifically needs GNU find, as well.
-RDEPEND=">=sys-apps/findutils-4.9"
-
-src_configure() {
- local emesonargs=(
- # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
- --prefix="${EPREFIX:-/}"
- --mandir="${EPREFIX}/usr/share/man"
- $(meson_use test tests)
- )
-
- meson_src_configure
-}