summaryrefslogtreecommitdiff
path: root/sys-apps/fbset/fbset-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset/fbset-2.1.ebuild')
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index d6d2979ad87a..282b230b79a3 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs flag-o-matic eutils
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="A utility to set the framebuffer videomode"
HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
@@ -14,15 +14,14 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86"
IUSE="static"
-DEPEND="sys-devel/bison
+BDEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
-src_prepare() {
- epatch "${FILESDIR}/${P}-build.patch"
- epatch "${FILESDIR}/${P}-add-linux-types-h.patch"
- default
-}
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-add-linux-types-h.patch"
+)
src_compile() {
use static && append-ldflags -static