summaryrefslogtreecommitdiff
path: root/sys-apps/eza/eza-0.18.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/eza/eza-0.18.6.ebuild')
-rw-r--r--sys-apps/eza/eza-0.18.6.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-apps/eza/eza-0.18.6.ebuild b/sys-apps/eza/eza-0.18.6.ebuild
index 2e5c5ec4a7ec..0bd577b67434 100644
--- a/sys-apps/eza/eza-0.18.6.ebuild
+++ b/sys-apps/eza/eza-0.18.6.ebuild
@@ -223,6 +223,12 @@ src_prepare() {
rm tests/cmd/absolute{,_recurse}_unix.toml
sed -i -e 's/^strip = true$/strip = false/g' Cargo.toml || die "failed to disable stripping"
+
+ if use git; then
+ # libgit2-sys unnecessarily(?) requests <libgit2-1.8.0, bump to 2 for now
+ sed -e '/range_version/s/1\.8\.0/2/' \
+ -i "${ECARGO_VENDOR}"/libgit2-sys-0.16.2+1.7.2/build.rs || die
+ fi
}
src_configure() {