summaryrefslogtreecommitdiff
path: root/sys-apps/entropy-server/entropy-server-302-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/entropy-server/entropy-server-302-r1.ebuild')
-rw-r--r--sys-apps/entropy-server/entropy-server-302-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/entropy-server/entropy-server-302-r1.ebuild b/sys-apps/entropy-server/entropy-server-302-r1.ebuild
new file mode 100644
index 000000000000..a3fb4d6d958a
--- /dev/null
+++ b/sys-apps/entropy-server/entropy-server-302-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager server-side tools"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+matter"
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}/server"
+
+RDEPEND="~sys-apps/entropy-${PV}[${PYTHON_SINGLE_USEDEP}]
+ matter? ( ~app-admin/matter-${PV}[entropy] )
+ ${PYTHON_DEPS}
+ "
+DEPEND="app-text/asciidoc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp "${S}/eit-completion.bash" eit
+
+ python_optimize "${D}/usr/lib/entropy/server"
+}