summaryrefslogtreecommitdiff
path: root/sys-apps/elivepatch-client/elivepatch-client-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elivepatch-client/elivepatch-client-9999.ebuild')
-rw-r--r--sys-apps/elivepatch-client/elivepatch-client-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-client/elivepatch-client-9999.ebuild b/sys-apps/elivepatch-client/elivepatch-client-9999.ebuild
new file mode 100644
index 000000000000..efd08c9166a8
--- /dev/null
+++ b/sys-apps/elivepatch-client/elivepatch-client-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch installer client working with elivepatch-server"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/aliceinwire/elivepatch-client.git"
+else
+ SRC_URI="https://github.com/aliceinwire/elivepatch-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ app-admin/sudo
+ dev-python/git-python[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"