summaryrefslogtreecommitdiff
path: root/sys-apps/dtc/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dtc/files')
-rw-r--r--sys-apps/dtc/files/dtc-1.7.0-meson-macos.patch39
-rw-r--r--sys-apps/dtc/files/dtc-1.7.0-meson-tests.patch27
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/dtc/files/dtc-1.7.0-meson-macos.patch b/sys-apps/dtc/files/dtc-1.7.0-meson-macos.patch
new file mode 100644
index 000000000000..473cd9a29e1a
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.7.0-meson-macos.patch
@@ -0,0 +1,39 @@
+https://git.kernel.org/pub/scm/utils/dtc/dtc.git/commit/?id=71a8b8ef0adf01af4c78c739e04533a35c1dc89c
+
+From 71a8b8ef0adf01af4c78c739e04533a35c1dc89c Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Wed, 31 May 2023 11:41:42 -0300
+Subject: libfdt: meson: Fix linking on macOS linker
+
+-undefined error is the equivalent of --no-undefined for the macOS
+linker, but -undefined would also be understood as a valid argument for
+GNU ld so we use the supported linker variant.
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
+--- a/libfdt/meson.build
++++ b/libfdt/meson.build
+@@ -16,10 +16,20 @@ sources = files(
+ 'fdt_wip.c',
+ )
+
++link_args = []
++if cc.has_link_argument('-Wl,--no-undefined')
++ link_args += '-Wl,--no-undefined'
++else
++ # -undefined error is the equivalent of --no-undefined for the macOS linker,
++ # but -undefined would also be understood as a valid argument for GNU ld!
++ link_args += cc.get_supported_link_arguments('-Wl,-undefined,error')
++endif
++
++link_args += version_script
+ libfdt = library(
+ 'fdt', sources,
+ version: '1.6.0',
+- link_args: ['-Wl,--no-undefined', version_script],
++ link_args: link_args,
+ link_depends: 'version.lds',
+ install: true,
+ )
+--
+cgit
diff --git a/sys-apps/dtc/files/dtc-1.7.0-meson-tests.patch b/sys-apps/dtc/files/dtc-1.7.0-meson-tests.patch
new file mode 100644
index 000000000000..0bc2d71aea1c
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.7.0-meson-tests.patch
@@ -0,0 +1,27 @@
+https://git.kernel.org/pub/scm/utils/dtc/dtc.git/patch/?id=32174a66efa4ad19fc6a2a6422e4af2ae4f055cb
+
+From 32174a66efa4ad19fc6a2a6422e4af2ae4f055cb Mon Sep 17 00:00:00 2001
+From: David Gibson <david@gibson.dropbear.id.au>
+Date: Tue, 28 Feb 2023 10:33:58 +1100
+Subject: meson: Fix cell overflow tests when running from meson
+
+Because meson always builds out-of-tree we need to reference things in the
+original source tree via $SRCDIR from run_tests.sh. We forgot a couple of
+cases for the cell overflow tests. Fix them.
+
+Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
+--- a/tests/run_tests.sh
++++ b/tests/run_tests.sh
+@@ -519,8 +519,8 @@ libfdt_tests () {
+ check_tests "$SRCDIR/phandle-args-overflow.dts" clocks_property
+
+ ## https://github.com/dgibson/dtc/issues/74
+- run_dtc_test -I dts -O dtb -o cell-overflow-results.test.dtb cell-overflow-results.dts
+- run_dtc_test -I dts -O dtb -o cell-overflow.test.dtb cell-overflow.dts
++ run_dtc_test -I dts -O dtb -o cell-overflow-results.test.dtb "$SRCDIR/cell-overflow-results.dts"
++ run_dtc_test -I dts -O dtb -o cell-overflow.test.dtb "$SRCDIR/cell-overflow.dts"
+ run_test dtbs_equal_ordered cell-overflow.test.dtb cell-overflow-results.test.dtb
+
+ # check full tests
+--
+cgit