summaryrefslogtreecommitdiff
path: root/sys-apps/dtc/dtc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dtc/dtc-9999.ebuild')
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
index 72cf9d539b46..ef30384edbe0 100644
--- a/sys-apps/dtc/dtc-9999.ebuild
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -42,7 +42,10 @@ DOCS=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ if use python ; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {