summaryrefslogtreecommitdiff
path: root/sys-apps/coreutils/coreutils-9.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/coreutils/coreutils-9.5.ebuild')
-rw-r--r--sys-apps/coreutils/coreutils-9.5.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-apps/coreutils/coreutils-9.5.ebuild b/sys-apps/coreutils/coreutils-9.5.ebuild
index 3e451f36d7cb..4d92094067f1 100644
--- a/sys-apps/coreutils/coreutils-9.5.ebuild
+++ b/sys-apps/coreutils/coreutils-9.5.ebuild
@@ -121,7 +121,10 @@ src_prepare() {
)
if ! use vanilla && [[ -d "${WORKDIR}"/${MY_PATCH} ]] ; then
- PATCHES+=( "${WORKDIR}"/${MY_PATCH} )
+ PATCHES+=(
+ "${WORKDIR}"/${MY_PATCH}
+ "${FILESDIR}"/${PN}-9.5-skip-readutmp-test.patch
+ )
fi
default
@@ -224,9 +227,6 @@ src_test() {
local -x gl_public_submodule_commit=
local xfail_tests=(
- # bug #629660
- tests/dd/no-allocate.sh
-
# bug #675802
tests/env/env-S
tests/env/env-S.pl
@@ -245,6 +245,12 @@ src_test() {
#tests/touch/not-owner.sh
)
+ # This test is flaky (bug #629660, bug #935367).
+ cat > tests/dd/no-allocate.sh <<-EOF || die
+ #!/bin/sh
+ exit 77;
+ EOF
+
# This test is flaky (bug #910640).
cat > tests/tty/tty-eof.pl <<-EOF || die
#!/usr/bin/perl