summaryrefslogtreecommitdiff
path: root/sys-apps/coreutils/coreutils-8.30.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/coreutils/coreutils-8.30.ebuild')
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index 91ea2d3a06db..99156b6acf85 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit eutils flag-o-matic python-any-r1 toolchain-funcs
@@ -54,6 +54,10 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup