summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-1.36.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-1.36.1.ebuild')
-rw-r--r--sys-apps/busybox/busybox-1.36.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-apps/busybox/busybox-1.36.1.ebuild b/sys-apps/busybox/busybox-1.36.1.ebuild
index a9f3d85703c7..8a030a712279 100644
--- a/sys-apps/busybox/busybox-1.36.1.ebuild
+++ b/sys-apps/busybox/busybox-1.36.1.ebuild
@@ -346,7 +346,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then