summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild')
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild
deleted file mode 100644
index edb084d8d17a..000000000000
--- a/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 linux-info meson
-
-DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
-HOMEPAGE="https://github.com/containers/bubblewrap/"
-SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-IUSE="selinux +suid"
-
-RDEPEND="
- sys-libs/libseccomp
- sys-libs/libcap
- selinux? ( >=sys-libs/libselinux-2.1.9 )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-text/docbook-xml-dtd:4.3
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-# tests require root priviledge
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${P}-clang-printf.patch
-)
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_configure() {
- local emesonargs=(
- '-Dbash_completion=enabled'
- '-Dman=enabled'
- '-Dzsh_completion=enabled'
- "$(meson_feature selinux)"
- )
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- if use suid; then
- chmod u+s "${ED}"/usr/bin/bwrap
- fi
-}