summaryrefslogtreecommitdiff
path: root/sys-apps/arrayprobe/files/2.0-ida_headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/arrayprobe/files/2.0-ida_headers.patch')
-rw-r--r--sys-apps/arrayprobe/files/2.0-ida_headers.patch30
1 files changed, 12 insertions, 18 deletions
diff --git a/sys-apps/arrayprobe/files/2.0-ida_headers.patch b/sys-apps/arrayprobe/files/2.0-ida_headers.patch
index fbdb20b87ea6..3cd744b32a33 100644
--- a/sys-apps/arrayprobe/files/2.0-ida_headers.patch
+++ b/sys-apps/arrayprobe/files/2.0-ida_headers.patch
@@ -1,6 +1,5 @@
-diff -Naur arrayprobe-2.0.old/cciss_events.h arrayprobe-2.0/cciss_events.h
---- arrayprobe-2.0.old/cciss_events.h 2005-12-27 10:51:29.000000000 +0100
-+++ arrayprobe-2.0/cciss_events.h 2010-01-13 15:46:53.000000000 +0100
+--- a/cciss_events.h
++++ b/cciss_events.h
@@ -27,8 +27,12 @@
#define QWORD __u64
@@ -14,9 +13,8 @@ diff -Naur arrayprobe-2.0.old/cciss_events.h arrayprobe-2.0/cciss_events.h
#define CompareEvent(event,par_class,par_subclass,par_detail) \
((event.class.class==par_class) && \
-diff -Naur arrayprobe-2.0.old/configure.ac arrayprobe-2.0/configure.ac
---- arrayprobe-2.0.old/configure.ac 2006-01-03 13:58:31.000000000 +0100
-+++ arrayprobe-2.0/configure.ac 2010-01-13 15:42:49.000000000 +0100
+--- a/configure.ac
++++ b/configure.ac
@@ -19,38 +19,6 @@
dnl Check for compile.h (2.6.x kernels only?
AC_CHECK_HEADERS(linux/compiler.h)
@@ -56,9 +54,8 @@ diff -Naur arrayprobe-2.0.old/configure.ac arrayprobe-2.0/configure.ac
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
-diff -Naur arrayprobe-2.0.old/cpqarray.h arrayprobe-2.0/cpqarray.h
---- arrayprobe-2.0.old/cpqarray.h 1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/cpqarray.h 2010-01-13 15:40:11.000000000 +0100
+--- a/cpqarray.h
++++ b/cpqarray.h
@@ -0,0 +1,126 @@
+/*
+ * Disk Array driver for Compaq SMART2 Controllers
@@ -186,9 +183,8 @@ diff -Naur arrayprobe-2.0.old/cpqarray.h arrayprobe-2.0/cpqarray.h
+#endif
+
+#endif /* CPQARRAY_H */
-diff -Naur arrayprobe-2.0.old/ida_cmd.h arrayprobe-2.0/ida_cmd.h
---- arrayprobe-2.0.old/ida_cmd.h 1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/ida_cmd.h 2010-01-13 15:40:29.000000000 +0100
+--- a/ida_cmd.h
++++ b/ida_cmd.h
@@ -0,0 +1,349 @@
+/*
+ * Disk Array driver for Compaq SMART2 Controllers
@@ -539,9 +535,8 @@ diff -Naur arrayprobe-2.0.old/ida_cmd.h arrayprobe-2.0/ida_cmd.h
+#pragma pack()
+
+#endif /* ARRAYCMD_H */
-diff -Naur arrayprobe-2.0.old/ida_ioctl.h arrayprobe-2.0/ida_ioctl.h
---- arrayprobe-2.0.old/ida_ioctl.h 1970-01-01 01:00:00.000000000 +0100
-+++ arrayprobe-2.0/ida_ioctl.h 2010-01-13 15:44:46.000000000 +0100
+--- a/ida_ioctl.h
++++ b/ida_ioctl.h
@@ -0,0 +1,87 @@
+/*
+ * Disk Array driver for Compaq SMART2 Controllers
@@ -630,9 +625,8 @@ diff -Naur arrayprobe-2.0.old/ida_ioctl.h arrayprobe-2.0/ida_ioctl.h
+} ida_ioctl_t;
+
+#endif /* IDA_IOCTL_H */
-diff -Naur arrayprobe-2.0.old/probe.c arrayprobe-2.0/probe.c
---- arrayprobe-2.0.old/probe.c 2006-01-03 14:11:17.000000000 +0100
-+++ arrayprobe-2.0/probe.c 2010-01-13 15:45:22.000000000 +0100
+--- a/probe.c
++++ b/probe.c
@@ -33,10 +33,9 @@
#include <getopt.h>
#include <errno.h>